Jump to content

Archived

This topic is now archived and is closed to further replies.

Framegirona

Tabtastic and shortcodes

Recommended Posts

Framegirona    3
Framegirona

Hi Ellen,

 

I'm using your plugin tabtastic on a new project and when I'll try to use a shortcode made by me on tabtastic it doesn't work properly.

 

When I use shortcodes from DMS I've no problems. I.E.

[pl_video type="youtube" id="Add video id here, see image above"]

This is the code that build my function

function getIconaSales(){
    
    if(get_field('numero_de_sales'))
    {
  	echo ('Sala');
    }
     

    }
add_shortcode('IconaSales', 'getIconaSales'); 

When I write [Iconasales] into your quicktabs  it does'nt works properly as is showed in the image

 

 

tabstastic.png

 

Thanks a lot

 

 

Share this post


Link to post
Share on other sites
Framegirona    3
Framegirona

I'm sorry if I'm bold but... Ellen can you help me? Thanks lot in advance and sorry again

Share this post


Link to post
Share on other sites
Framegirona    3
Framegirona

ellenmva Any answer please? Can you give support please?

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

Framegirona I am very sorry to not get back to you sooner. I've had the flu :( and got behind.

 

Could you try wrapping your shortcode with [pl_raw] [your_shortcode] {/pl_raw]. 

 

Let me know if that works.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Framegirona    3
Framegirona

Hope you feel better. I'll try in a few

Share this post


Link to post
Share on other sites
Framegirona    3
Framegirona

It works as a charm!!! Thank you

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      We're often working with ACF (https://www.advancedcustomfields.com/) that's great for user experience in the backend, 'cause we don't want out clients to be in the editor to much.
      So we want to be able to use shortcodes in the editor fields, regardless of section, THIS WOULD BE SO GREAT. Is there a way to fix this, it should open up som much more functionality.
      In ACF, the shortcode is for example: 
      [acf field="field_name"] ...for example, I want to att field_names value to display in a section, i understand I can make it in embed and so, but I want it in titles and options, the whole range.
      I know I can build my own sections, that we've done, but it's not very effective, and thats what PL5 is about.
      Any ideas on this, can Pagelines take this in the core? I guessing there are more than just ACF out there who can use this.

    • jojoking
      By jojoking+
      I have to admit to being baffled.
      I'm trying to embed a video (from my WP media library) within a WP post using the videobox section shortcode.
      The shortcode section popup only allows two items to be configured - the section type, in this case videobox - and a unique id. There's no URL or other parameters such as autoplay or loop which are available within the Pagelines editor.
      Whatever I put in the unique ID makes no difference to what is shown which seems to be a default video with stars or white noise on a black background.
      I assume I need to define this ID somewhere else, or maybe WP has done it for me?
      HELP!
       
      PS This is the page source generated when a shortcode is added within the WP post editor
      <!-- VideoBox | Section --> <section id="videobox_1675853156" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="1675853156" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="280414138" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/plugins/pl-section-videobox/default.mp4?r=280414138" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#280414138')[0].load(); </script> </div> </div></div></section> </div>  
      If I add a videobox section using the Pagelines page editor the page source generated includes my video:
      <!-- VideoBox | Section --> <section id="videobox_udvu4uz" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="udvu4uz" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="429558737" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/uploads/2017/04/HIHWelcome.mp4?r=429558737" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#429558737')[0].load(); </script> </div> </div></div></section>  
    • bnapoli
      By bnapoli+
      On my site www.anewbeginning.com the "toggle" function mysteriously stopped working.  I have tried all browsers, tried disabling plugins, removing all the relevant CSS but still cant understand why it isn't working.
      The toggle is placed on this page: http://anewbeginning.com/?page_id=15965 and http://anewbeginning.com/?page_id=10779 but it does not display.
      On my other Platform5 websites, that exact code works fine: see here http://4aa.d11.myftpupload.com/?page_id=123
      Code is the same. Please help, thank you!
    • Samuel Costa - UDF
      By Samuel Costa - UDF+
      Hi.
      I need a shortcode activate a popup windows with contact form. It is possible without code?
      Link: https://www.udf.org.br/lancamentos/curso-mulher-que-prospera/
      Button: FAÇA SUA INSCRIÇÃO.
      Tks
    • flourishdesignstudio
      By flourishdesignstudio
      Hello, 
      I am having a problem with shortcode not working properly with the PL5 theme. I have been trying to insert shortcode for a specific plugin (Map List Pro) and it has worked when I am using DMS but not with PL5. When I insert the shortcode into the page content then none of the content (text, images, or map) will load on that page. Thinking that maybe a widget or straight HTML code would work better made me try inserting the shortcode into a widget (didn't work) as well as an embed section within PL5. The embed section worked in that I can look at the code and see that the map is there but nothing is actually displaying on the page.
      I am also unable to edit the embed code section (added through PL shortcode into the content of the page) once I have put in the Map List Pro shortcode. Any thought as to a workaround or if the codes are somehow interfering with one another? You can see the page (and gap where the map is supposed to be loading) here: http://new.fingerlakesdistilling.com/where-to-buy
      Thanks so much for any insight you are able to provide!
×