Jump to content

Archived

This topic is now archived and is closed to further replies.

xcel7

category pages don't accept local changes on DMS

Recommended Posts

xcel7    1
xcel7

Hello,

 

My problem is with the category pages. It's the same page except one is in french, the other one will be in english (no need to use WPML here, just a few pages), so they call the same posts with two different tags : "actualites" and "news"

 

http://wouapy.octanteine.com/category/actualites

http://wouapy.octanteine.com/category/news

 

I chose to have a different highlight and a different menu in each of these pages, but the same content (maybe from Facebook).

And when I change the highlight content and the menu settings, the last change is applied on BOTH pages.

 

Do you know how to fix that?

 

TIA

 

Ines

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

You can apply style to a particular page using the page id of the page you want to change as a prefix in your CSS code. 

 

To find out the page id of the pages you are applying the particular style to - go to your Wordpress > pages > all pages and hover over a particular page. at the bottom of the screen in the info bar you will see the ID of the page. Take note of this. 

 

Lets say the ID of the page is 166 

 

To apply CSS to that particular page we would add 

.page-id-166

 to the start of our CSS. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
xcel7    1
xcel7

Hello Martin,

How I do that on a category page?

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Ok - try changing your permalinks settings to Post-ID and then load the Category page - this should give you the ID to use. :) 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
xcel7    1
xcel7

Hello Martin,

I don't want to loose my permalinks settings, so I tried another way to do it, by creating a page to publish FB feed. But doing so it will create duplicate content :-(

That's why I would really appreciate if the local settings could be used.

If I use the page ID, how I call all my sections in french in a page, and all my sections in english in another? Do I have to create double sections on each page and call them by using a class? double navbar, double highlight?

TIA

Share this post


Link to post
Share on other sites
xcel7    1
xcel7

Is it because it' in the header section? But I managed to change the navbar on local for pages, not for post pages…

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, post pages all use the post template, so changes made on that template get reflected on the other post/category/archive templates etc. So if you add highlight to the post page, it will appear on all post pages etc. But you still have the option inside the section settings to set the local options for that section - http://screencast.com/t/vTGPOkZ0t46. So even though the highlight will appear on all post pages, you can chose different versions between those post pages.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
xcel7    1
xcel7

Hello,

That is exactly what I am looking for, the same sections in my post pages but with a different content… And it does NOT work for me. Every time I change the content in the LOCAL options, the change appears on both pages. Maybe it could be because of the use of categories, I want the same posts (categories : "news" AND "actus" for all of them), but a different navbar and highlight (one in french, one in english). I think I have to duplicate the posts and give them each a unique category, but then I'll have duplicate content… or maybe what I want to do IS ducplicate content anyway…

Thanks for your help

Share this post


Link to post
Share on other sites
xcel7    1
xcel7

Helloooo?

 

What can I do to resolve my problem?

I put the navbar and masthead and highlight in the template section (instead of in the header section), I change their content in local, and the last change applied is visible on BOTH category pages…

Mayday!!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Unfortunately, it is not possible at the moment to have different category pages. This has been reported already and our developers are aware of the issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Chris Pallé    0
Chris Pallé

Is there an update to this? I'd like to have the ability to control local changes on my Custom Taxonomy pages. Also, it would make sense to have different local edits for Custom Post Types that are in different categories. 

 

Thanks, 

Chris

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Unfortunately, this still isn't possible at the moment. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • JP
      By JP+
      Hello,
      We are working on a 2 languages site (https://liguecardioliga.be) with wpml, and lately the call of a category in the loops section (and all the sections requiring a category to select posts) doesn't work in the translated language. It worked well until recently so I wonder if it's because of a recent update (wordpress, wpml, pagelines, a plugin?). Anyone has the same problem? a solution?
      TIA
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
×