Jump to content

Archived

This topic is now archived and is closed to further replies.

wendygordon

DMS & WPML images not loading

Recommended Posts

wendygordon

I am using the framework Pagelines DMS and the latest version of WPML. I am having trouble with images that show up only in the english version but not in the translations. In this case I am trying to put an image into the hero section for all language versions. and even though I am able to select the image in all cases from the media library – the image shows up only in the english version and shows as a broken link in the french and spanish versions. I am hoping you can help. the site is scheduled to go live this week.
Thanks so much.

Share this post


Link to post
Share on other sites
ketri

If I understood correctly I have the same issue. 

This happens in the translated site because WPML changes the home ([pl_site_url]) from yoursite.com ---> yoursite.com/en

 

So

[pl_site_url]/wp-content/uploads/2014/01/favorite.jpg

ends up being: 

<im src="http://yoursite.com/en/wp-content/uploads/2014/01/favorite.jpg">

And the image does not exist there. It should be:

<im src="http://yoursite.com/wp-content/uploads/2014/01/favorite.jpg">

So the [pl_site_url] has the "/en/" thing if the language is english (or other second language) and the url is not correct. 

You can fix this by substituting the [pl_site_url] -part with your site url. For example instead of "[pl_site_url]" you put "http://mysite.com"
But we of course want a better fix.

 

Share this post


Link to post
Share on other sites
wendygordon

ketri- thanks so much for responding.  yes.  I found that in each case where there is an image inside a DMS section, i needed to go to the actual path for the image within each section and manually replace [pl_site_url] with http://www.mysite.com - this worked like a charm.  i didnt try it, but i wonder if a plug in like Velvet Blues would be a good solution to do a batch replace.

Share this post


Link to post
Share on other sites
James B

Velvet blues will allow you bulk change the urls used.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
interpro

I also have this issue with broken images in different languages - is there a way to show different images for different languages, as some of our images have captions as part of the image?

Share this post


Link to post
Share on other sites
greenfly

Could you create a new topic for this with links to your site and more information and we will be able to help 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

×