Jump to content

Archived

This topic is now archived and is closed to further replies.

balfred1345

Workaround for Needing to Clear all CSS/LESS cached data after each change?

Recommended Posts

balfred1345    5
balfred1345

The issue of the Custom CSS/LESS Editor not saving reliably (unless click out of the Custom CSS/LESS editor and save, then keep fingers crossed) has really been getting me down.

 

So, I've changed my setup to edit the style.less file directly in my Child Theme via Sublime.

 

Long story short, I then encountered a similar-seeming problem nonetheless. After disabling my plugins (except for DMS Pro), and turning off all my browsers' cache / automatically clearing cache on each browser refresh, I still had the problem.

 

It turns out that the DMS Cache wasn't clearing, so I have to go to Resets/Clear All CSS-LESS cached data/Flush Caches each time after making a CSS/LESS change in order to see my changes. I don't know why this is the case, since I've updated the CSS/LESS directly via Sublime, and am not using DMS.

 

Is there a workaround for needing to clear the DMS cache each time. In particular, is there a way to turn off CSS/LESS caching in DMS? If so, is it do-able for a front-end guy who doesn't know PHP?

 

I'm using WP 3.8 and DMS 1.1.4.

 

Thanks,

Bruce

Share this post


Link to post
Share on other sites
James B    436
James B

Hi Bruce

 

Please see - http://forum.pagelines.com/topic/30804-stopping-pagelines-dynamically-serving-css/ there's a code snippet in there than Simon has added which will help.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Simon    247
Simon
Actually no, what you want is LESS developer mode.

It will recompile the css every time you edit the files.

Add to wp-config.php

define( 'PL_LESS_DEV', true );

Share this post


Link to post
Share on other sites
balfred1345    5
balfred1345

Thanks very much for the replies. I added

 

 define( 'PL_LESS_DEV', true );

 

and it did the job. Thanks -- brings my frustration level way down.

 

What is the best way to stay in the loop about these little nuggets that make life easier for those of us using PL to make completely custom sites? I searched the forum and other PL "community" sites for solutions to this issue, but didn't come up with any helpful threads.

PL 300?

 

Thanks again,

Bruce

Share this post


Link to post
Share on other sites
James B    436
James B

Hi Bruce, excellent glad that worked for you.

 

To be honest those little snippets come up every now and then depending on the problem the user is having, recently we've included a number of these snippets in the pro tools plugin to try and make life easier, but there's always going to be new ones coming up as someone else finds a different issue and a new solution comes to light etc. If the snippet is beneficial to everyone it will probably be added to the pro tools plugin going forward.

 

For the ones where it's down to specific circumstances, server restrictions etc, the best way at the moment if you can't find a solution is to drop a post and one of the mods will be able to find it for you or advise further. Things like that can be hard to find as sometimes the solution isn't necessarily whats reflected in the forum title.

 

The 300 is a great resource as well and as it's a community group a lot of the members will already have come across those questions so yes I'd advise considering to join the group as well.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
balfred1345    5
balfred1345

Thanks, James.

I've just put my name in for PL 300.

 

As always, really appreciate your help.

 

-Bruce

Share this post


Link to post
Share on other sites
James B    436
James B

You're welcome Bruce, that's great news. Someone from the 300 team will get back to you on your application shortly.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • jeomiland
      By jeomiland+
      In DMS2 there was a button to click to flush pagelines cache. Don't see this in platform5. Am having a big problem with caches. Have W3 Total cache plugin, but now even if I deactivate it, the code in css/less seems to not be registering??? I can delete all custom css, save, then add just a bit of the css (that used to work just fine the other day) and that small section of css takes effect. Then when I paste the whole css (that worked fine the other day), it seems to not work???
      About to restore DB backup from a couple days ago to see if that solves it, but it's a drag that this issue exists. Makes it hard to finetune the site.
      Thanks for help
      site is: http://permacultureecovillage.com/lev2017/
      lev styles most recent.css.rtf
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
×