Jump to content

Archived

This topic is now archived and is closed to further replies.

kirsten

Menu keeps wrapping to two lines

Recommended Posts

kirsten

Hi

My menu keeps wrapping into two lines in Firefox, even though I have made the search box quite small.

Tried to change the font and also letter spacing for the secondary font in page line settings but they stay the same.

What can I do and why isn't the font changing?

The site is bureaunetwerk.nl

ThanX ! Greetings Kirsten

 

Share this post


Link to post
Share on other sites
Danny

Hi Kirsten,

 

The reason for this is that the ul class has a set width, so all we need to do is increase that width to house all your menu items. So add the following to your custom CSS:

 

#site ul.main-nav {
width: 700px;
}
 
Also, I have set it so that there should be enough room for both your search bar and navigation links, so you can remove the styling you have added to reduce the search fields width.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
James B

Glad it worked, thank you for updating the thread and letting us know.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
honeytrek

hey guys i am also having an issue with my navigation not fitting. i added that CSS to  (PlatformBase -> Style.css ....is that the right place). And still wraps my menu.

 

How can I shrink the search box to leave more space for the nav items?

 

I have tried editing the CSS (

PlatformPro: Stylesheet (style.css)

)a

 

I shrunk   .searchform .searchfield{

and i shrunk .searchform {

 

but neither seemed to do the trip and allow my menu to go back to one line.

 

FYI, this all started happening after I added the leaderboard banner to my header. I did not modify my navigation at all when the double line started occuring.

 

Thanks so much guys for your awesome support,

Mike

 

Website URL: www.HoneyTrek.com
Framework Version:  Pagelines Platform Pro 1.5.3 (my system will not allow me to upgrade to 1.6.0 for some reason, been trying for many weeks.
WordPress Version: 3.8
Plugins in Use: numerous
Server/Host: BlueHost.com
Screenshots:
Details: see above

Share this post


Link to post
Share on other sites
James B

Hi there,

 

Looking at your site its the actual nav width which needs to be adjusted slightly to get everything to appear on one row. If you adjust the figure using css to around 745px like in the screenshot below you should find everything moves back onto one line. I've highlighted the css causing this in the text editor for you.

 

http://screencast.com/t/fgjM1P7A0


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      Todd
       
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
×