Jump to content

Archived

This topic is now archived and is closed to further replies.

outtareach

Cannot Remove Space On Top Of Textbox

Recommended Posts

outtareach    3
outtareach

I have a text box with 0px 0px in the css settings and yet in chrome it is still not aligned on the top flush with the image on the left.  It looks better in firefox but still I need it to look correct in both. this was never an issue before but now it seems to be happening in the update. Seems to be the space for the title which I do not have and I need to remove the space.

 

car.png

  • Like 1

Share this post


Link to post
Share on other sites
James B    436
James B

I would imagine this is either coming from the title container, which you'd need to set to display:none probably or from a margin or padding on the <p> tag. If you have a live link to the site we can look in the source code and advise further for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
ketri    7
ketri

This issue seems to be in all TextBoxes without a title. The title is seen in the page as a  <strong>Title stuff </strong>, which doesen't seem to be a problem. The problem is a <br> between the title and the Text Content. It does not have  a class so it can't be removed without removing all the other possble <br>s in that text box. 

TextBox should automatically not show the title or <br> if it is empty or it will hive users headaches.
Do you have a better solution for this? 

Horrible solution:

.textboxclasshere br{display none}
.textboxclasshere br.visible {display:block;}

But I'd rather hack the textbox section or something.

Share this post


Link to post
Share on other sites
kulmetehan    13
kulmetehan

So no official progress on this subject yet? I ran in to the same trouble. It really is a pain.

Share this post


Link to post
Share on other sites
outtareach    3
outtareach

still have it, it was never like this before the update.  before the update I would just put 0px 0px and then adjust the default section padding a bit but now that doesnt change anything.  A fix would be great because this is just annoying and you have to either put a title in or move the image down with padding.

Share this post


Link to post
Share on other sites

  • Similar Content

    • lbhansen
      By lbhansen+
      I am slowly getting closer to something I like for the general appearance of my site. What's currently nagging me is trying to remove the top and bottom padding/margin from the image in the header. It seems that I've done what I want with the menu but there was dead space above the image and between the image and menu.
      Trying out padding and margin settings, I got something that came close to what I want but saw odd behavior along the way. Changing either the top or bottom padding to 0 (from blank), removed all padding from the top and sides but left a small band between the image and menu.
      Setting all eight padding and margin settings to 0 removed all except the band between image and menu. (But it seems that entering 0 in only the top or bottom padding option is all that was needed.)
      So, heading into the twilight zone, I changed the bottom margin to -1. That removed the band but allowed the menu to slightly overlap the image. AND, narrowing the browser, or viewing on a phone, caused the band to reappear.
      Perhaps there's also a problem with the menu but I don't see it.
      So that's where it stands at the moment: http://756.a44.myftpupload.com 
      I seems to me that if there is a default padding value, setting it to 0 should be all that's needed to get the two sections to meet perfectly on any device/browser width.
    • Perry
      By Perry+
      Hello There, 
      I am working with Platform 5 and have run into an unnerving problem. I am trying to position my clients picture along the bottom of the container, so that it sits right on the bottom. After a good hour of googling and messing with the CSS I figured I would ask the question here. Below is my screenshot displaying my problem. I will need to do this frequently in the future. 
      My Problem Image
      Unlike in DMS, when I add a margin to an embed or image box it simply makes the container larger while keeping the padding, I cannot have any padding or any space whatsoever on the bottom of my clients image.  Is there a way to remove all padding from the container so I can have this work across screen sizes? If not is there anyway to position an element directly at the bottom of another element in Platform 5? This seems like a basic feature and was easily attainable within DMS. 
      I cannot create an image combining all these elements as it will not scale well on mobile and will make my clients logo unreadable and her face incredibly small. 
       
      Thank you for any help,
      Perry
    • chamois_blanc
      By chamois_blanc+
      Hello,
      I am a bit confused about the usage of percentages for section padding/margin settings in the PL5 UI. Percentages don't scale well for mobile devices (especially in height), so those settings are pretty much useless. Case in point, the defaults are expressed in rem units, not percentages:
      .pl-sn-pad { padding: 1rem; ... } Why force the user to use percentages in the PL5 section UI when it would have been as easy to let the user specify the unit?
×