Jump to content

Archived

This topic is now archived and is closed to further replies.

fritzfeger

Shortcode in main content ("CONTENTS" from WP Events Manager) overwrites banners

Recommended Posts

fritzfeger    0
fritzfeger

Hi there, on the page http://agroblogger.de/regio/unternehmen/, there's the plugin Events Manager (from the Word Press PlugIn Directory) which lets you select any page as events list and, at the place where you insert the code, creates that list. Leaving your text and HTML above and below untouched. You can see the list (with only one entry) under the headline "Termine" in the middle of the page.

 

There's a banners section below the content, and the banners now also display the events list, each of them.

 

Can I suppress that somehow? I'd love to see the real banner text instead of what that shortcode produces.

 

Thank you! 

Fritz

Share this post


Link to post
Share on other sites
James B    436
James B

Hi Fritz,

 

I can see the first entry on the page, but I can't see the second entry in the banner. Can you please take a screenshot and highlight the parts we need to look at for you.

 

As this is a third party plugin, I would image they are saving the content as a custom post type and the shortcode then pulls that content in. Depending on how the plugin has been constructed it could be that there's something code wise in the banner area which is triggering this to be pulled in as well, the best person who would be able to answer this for sure though would be the product developer as they know which code they've added and how it behaves etc. I would advise also posting a thread on the plugin support page with a link to the site so the plugin author can take a look and advise further. 


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
fritzfeger    0
fritzfeger

Hi James, thank you for your reply,

 

find attached the screenshot where the generated content is marked by the subtle red circles. You see it once on the page (top) as expected, but it also shows up in the banner (bottom). Interestingly, the banner title (my name in this case) is not overwritten, only the banner text. Same with every banner on that page following below the one on the screenshot.

 

I've posted the issue on the PlugIn developer's site, thanks for the hint.

 

If the problem lies where you assume it would be impossible to solve except the PlugIn author rewrites her PlugIn, right? I'll find a workaround (without banners on that page)...

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, if it's only happening on the banners then if you don't use them on the pages that the events plugin is active on hopefully it shouldn't occur.

 

What is the code they ask you to add to the page for the plugin to be active? I don't think the dev will need to rewrite the plugin, but they might be able to provide an additional line of code you can add which will stop it overriding the banner. Also in your banner, the standard content you have inside the banner is just text? And that's whats being overwritten in each one, but the title stays? In the meta settings, the banner set you've selected is still showing the same set as before?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
fritzfeger    0
fritzfeger

Hi James, the banner text is only overwritten on the page the events plugin is used; on other pages the banners work properly. The code to add to the page to activate the plugin is simply the word CONTENTS, no braces, brackets etc., in caps. The banner text has <a> tags but otherwise only text, and this is what's being overwritten whilst the title stays, exactly. The banner set selection works as expected.

 

Thank you for the idea with the additional line of code, I'll forward that to the plugin dev.

Share this post


Link to post
Share on other sites
James B    436
James B

Strange, definitely sounds like their code is mimicking something which is included in the core banner code. Keep us posted let us know what the developer says.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      We're often working with ACF (https://www.advancedcustomfields.com/) that's great for user experience in the backend, 'cause we don't want out clients to be in the editor to much.
      So we want to be able to use shortcodes in the editor fields, regardless of section, THIS WOULD BE SO GREAT. Is there a way to fix this, it should open up som much more functionality.
      In ACF, the shortcode is for example: 
      [acf field="field_name"] ...for example, I want to att field_names value to display in a section, i understand I can make it in embed and so, but I want it in titles and options, the whole range.
      I know I can build my own sections, that we've done, but it's not very effective, and thats what PL5 is about.
      Any ideas on this, can Pagelines take this in the core? I guessing there are more than just ACF out there who can use this.

    • jojoking
      By jojoking+
      I have to admit to being baffled.
      I'm trying to embed a video (from my WP media library) within a WP post using the videobox section shortcode.
      The shortcode section popup only allows two items to be configured - the section type, in this case videobox - and a unique id. There's no URL or other parameters such as autoplay or loop which are available within the Pagelines editor.
      Whatever I put in the unique ID makes no difference to what is shown which seems to be a default video with stars or white noise on a black background.
      I assume I need to define this ID somewhere else, or maybe WP has done it for me?
      HELP!
       
      PS This is the page source generated when a shortcode is added within the WP post editor
      <!-- VideoBox | Section --> <section id="videobox_1675853156" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="1675853156" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="280414138" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/plugins/pl-section-videobox/default.mp4?r=280414138" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#280414138')[0].load(); </script> </div> </div></div></section> </div>  
      If I add a videobox section using the Pagelines page editor the page source generated includes my video:
      <!-- VideoBox | Section --> <section id="videobox_udvu4uz" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="udvu4uz" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="429558737" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/uploads/2017/04/HIHWelcome.mp4?r=429558737" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#429558737')[0].load(); </script> </div> </div></div></section>  
    • bnapoli
      By bnapoli+
      On my site www.anewbeginning.com the "toggle" function mysteriously stopped working.  I have tried all browsers, tried disabling plugins, removing all the relevant CSS but still cant understand why it isn't working.
      The toggle is placed on this page: http://anewbeginning.com/?page_id=15965 and http://anewbeginning.com/?page_id=10779 but it does not display.
      On my other Platform5 websites, that exact code works fine: see here http://4aa.d11.myftpupload.com/?page_id=123
      Code is the same. Please help, thank you!
    • Samuel Costa - UDF
      By Samuel Costa - UDF+
      Hi.
      I need a shortcode activate a popup windows with contact form. It is possible without code?
      Link: https://www.udf.org.br/lancamentos/curso-mulher-que-prospera/
      Button: FAÇA SUA INSCRIÇÃO.
      Tks
    • flourishdesignstudio
      By flourishdesignstudio
      Hello, 
      I am having a problem with shortcode not working properly with the PL5 theme. I have been trying to insert shortcode for a specific plugin (Map List Pro) and it has worked when I am using DMS but not with PL5. When I insert the shortcode into the page content then none of the content (text, images, or map) will load on that page. Thinking that maybe a widget or straight HTML code would work better made me try inserting the shortcode into a widget (didn't work) as well as an embed section within PL5. The embed section worked in that I can look at the code and see that the map is there but nothing is actually displaying on the page.
      I am also unable to edit the embed code section (added through PL shortcode into the content of the page) once I have put in the Map List Pro shortcode. Any thought as to a workaround or if the codes are somehow interfering with one another? You can see the page (and gap where the map is supposed to be loading) here: http://new.fingerlakesdistilling.com/where-to-buy
      Thanks so much for any insight you are able to provide!
×