Jump to content

Archived

This topic is now archived and is closed to further replies.

leftcoastmichael

Assigning Fonts for different Elements

Recommended Posts

leftcoastmichael

I would like to change the font TYPE and SIZE for these elements: Paragraph, H1, H2, H3, H4, and H5.

 

I would also like to specify a different font TYPE and SIZE for menu bars and widget items.

 

I've looked and looked, and all I can see is the Global Setting -> Typography which does not offer options beyond "Primary Text" and "Text headers".  When I made a change to "Primary Text" , it changed everything (including Nav Bar and Widget texts), and when I made a change to "Text Headers" there was no option to specify font sizes for each of the H elements.

 

The 'old' Pagelines offered easy customization of all these elements. Now I'm lost.

 

Grateful if you could point me in the right direction.

Share this post


Link to post
Share on other sites
James B

Hi there,

 

These settings are generalized in DMS. You will need to use css to adjust the specific h tags on selected elements. Example of the css belwo for you.

 

h1, h2, h3, h4, h5, h6, p {
    font-size:18pt;
}

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
leftcoastmichael

Thanks for the response. Can you remind me where to input this code?

Share this post


Link to post
Share on other sites
Danny

All custom CSS/LESS can go into the Custom CSS option in the DMS Toolbar. However, if you're using a child theme, then your custom CSS/LESS should go into the style.less file, if there isn't one present then you will need to create it.

 

I recommend you see our Customization documentation for a more in-depth guide.

 

http://docs.pagelines.com/customize/how-to-customize

http://docs.pagelines.com/tutorials/adding-custom-fonts


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • DonRicardoRVM
      By DonRicardoRVM+
        First of all, sorry for my bad English.  I am developing an ecommeece with wp, woocommerce, PL5 and quickshop, and I need to do some changes in the simple product grid. I want to change the classes of some divs, but I can't find the templates. 
      Also, I change the grid of the category products pages, but I didn't make it correctly.
      This is the cat archive's: http://globosdemar.com/wp/categoria-producto/camisetas-para-ninos-y-ninas/
      Can you help me?
×