Jump to content

Archived

This topic is now archived and is closed to further replies.

jamesmaccer

mobile & ipad view - my solution & question re: placing of logo in mobile view

Recommended Posts

jamesmaccer

Hi, 

 

Regarding my site fmp investor relations. I checked the forums for a solution to the mobile view & the recommended answer was a link to this page

 

https://github.com/pagelines/DMS/blame/Dev/less/responsive.less

 

This didn't work for me, but what did was entering the CSS:

 

@media (max-width: 767px) {   .hidden-desktop {     display: inherit !important;   }   .visible-desktop {     display: none !important;   }   .visible-phone {     display: inherit !important;   }   .hidden-phone {     display: none !important;   } }

 

However, 1 minor problem. the logo on my site (top left) looks great in all views except mobile (it gets placed above the nav bar, rather than to the left of it - see site in mobile view to see what I mean). I therefore tried hiding the logo in mobile and putting another logo in for mobile view using the .visible-phone css. Works great, BUT at around 767 - 780 px I get both the logo's (i.e. the one which i've hidden in mobile, and the one i've hidden in desktop). Anything below 767px, I get one logo and anything above 767 - 780 px I get 1 logo. Any ideas?

Share this post


Link to post
Share on other sites
greenfly

Could you paste in your code that deals with your media breakpoints to here http://forum.pagelines.com/pst/

 

Add the link tot he paste in the forum here for us and we will be able to advise how to rectify this 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
James B

Have you managed to resolve this since posting, when resizing the page I only see the one logo on the current site as it resizes, at the top of the page as it goes into mobile view. http://screencast.com/t/Qkx6HyGe


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

×