Jump to content

Archived

This topic is now archived and is closed to further replies.

Ireneusz Luczak

Nav bar not linking to pages

Recommended Posts

Ireneusz Luczak    0
Ireneusz Luczak

Ive got a nav bar in my header with many subpages under my main menu pages. The problem is that I can click on all the categories in the 'clients' tab, but not on the 'clients' page. I tried deactivating the plugins and it didnt help the issue? 

 

www.fireflywebdesign.us 

The nav bar is on there and working for pages without subpages. Am I missing something very basic?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

This isn't a bug or an issue, it's just how the navigation was designed. The Fixed Navbar and Navbar section are based on the Bootstrap navigation design. The way it works is that when you have a menu item that has a sub menu, you access that sub menu by clicking the parent menu item, which is no longer a link but an anchor, which activates the sub menu.

 

If you do not like this functionality, I recommend you check out the Ubermenu plugin.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Ireneusz Luczak    0
Ireneusz Luczak

Gotcha! Just wanted to make sure. Makes my life easier since I don't have to design the 'Clients' page anymore. Although, If I use a site map, does the anchor page still show up? Should my 'clients' page be linked to an actual page within my menu or can I leave it unlinked?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, you can leave it unlinked if you want to, but if the page is still live and you haven't deleted it then it will still be indexed in search engines.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
    • tristanrodgers
      By tristanrodgers+
      Hi there!
      I'd love to have some social media buttons in my navbar like my online-shop has!
      http://mc1r-magazine.com/
      Can someone explain me how to create them? I tried a lot but don't know how to realize them...
      Greetings from Germany,
      Tristan
    • jeomiland
      By jeomiland+
      Hi guys. Just now trying out Platform 5. I like the reletive simplcity of the new interface but there are things I'm used to in DMS that I'm not seeing yet in 5. Is there a good manual, documentation, video series about some of the basics?
      In particular, I've got a simple navigation menu, created the standard way in WP menus section with several top level parents, then 3-4 children menu items below a couple parent items. Have them moved to the right to create the standard parent-child relationship but all I see on the page is the parent level items - no dropdown!. So I changed themes from Platform5 to the standard 2015 default theme and now I see absolutely no menu at top, except for the mobile (hamburger?) icon.
      In DMS, one had Navi and Navbar, etc sections and each would work differently and give different results. How do you work the menu system in 5? And how get different results ?
      thanks
    • nizami
      By nizami+
      I have a problem at http://kambo.world. Using navbar for the main site navigation. It works fine in normal/desktop mode [first screenshot], using the WP Menu I have specified. But in hamburger mode it seems to do its own thing, picking a few pages at random [second screenshot] A fix for this greatly appreciated! 
       


×