Jump to content

Archived

This topic is now archived and is closed to further replies.

sheilahoff

Hide Thumbnails not working

Recommended Posts

sheilahoff

I've done this on other sites but this site won't seem to save the setting. Using WP3.8 and newest DMS. Using featured image and do not want it repeated on the post. This may be to do with it being a calendar post: http://tca.hoffmangraphics.com/ai1ec_event/alabama-tandem-weekend/?instance_id=202

 

But I've done this same calendar and been able to check hide thumbnail and not have two on a page as this page shows.

 

I go to this page, edit loop, check hide thumbnail, make sure it's saved (green light) do a refresh and still have 2 images. What am I doing wrong?!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Try disabling all active plugins except for DMS Pro Tools and see if that resolves the issue. Also, in your URL what is the ?instance-id-XXX ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Danny, the instance ID is for the calendar listing.

 

I realize that disabling plugins is a standard troubleshooting instructions. But I find it quite annoying that when I have done that I end up having to re-do a lot of things in PL Sections! Also, in this case, if I disable the calendar plug-in it's not useful as that is the page that has the issue.

 

But you're confirming that what I'm doing SHOULD be the correct approach?


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

I haven't tried with the Calendar plugin installed not sure what calendar plugin you're using. However, what you could try is this (you may have ran into the settings not saving bug):

 

1. Go to the page you wish to hide the thumbnail from.

2. Check the box to hide the thumbnail.

3. Now click on another option field, when you do this, it should trigger the Saving progression icon next to the Publish button.

4. Wait until this progression completes, once it has, click the publish button and see if this resolves your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

Sadly I already knew that trick and that doesn't do it. Not sure why this one thing is not working or if there's some other way to make it so I don't have duplicate images on each calendar listing (custom post) as here: http://tca.hoffmangraphics.com/ai1ec_event/malcolms-offroad-event/?instance_id=210


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
sheilahoff

OK, I emailed the plug-in maker who provided me with CSS. I just don't know why I was able to clear the thumbnail in two other sites this way but not this one. Oh well... here's the CSS in case it helps anyone...

.attachment-landscape-thumb.wp-post-image {
display: none;
}


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

This may come across as stupid, but do those posts that have no featured image, actually have no uploaded featured image ?

Have you checked ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sheilahoff

The ones that were showing duplicates all had an uploaded featured image and nothing added into the post itself. There are some that had none but then they displayed none. The CSS the plugin folks provided seems to have done the trick though. thanks.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

Yeah the CSS will work, but its just masking the problem, it isn't a fix, the images are still loading. If you have this working on two sites, I recommend you review both of them and the one that this isn't working on and see if there are any differences.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×