Jump to content

Archived

This topic is now archived and is closed to further replies.

appappnost

Section width LESS/CSS being ignored ...

Recommended Posts

appappnost

Website URL: http://www.buddyflip.com/
Framework Version: 1.1.4
WordPress Version: 3.8
Plugins in Use: 
DMS Professional Tools
Server/Host: your-site.com

Screenshots: attached

Details: I added a 10px border around two sections on the site - which made it look like those sections were 20px larger than the other sections. So - I went in and added " width: 868px !important; " to the custom LESS/CSS for those sections - and - it works when in the editor mode of DMS - but then in preview mode - it completely ignores the designated width and the sections are too wide again. I've read through - and have tried a couple of things - got to the point where I added the " !important " - and that made it work in the editor mode - but then - once live, ker-flooey.

Share this post


Link to post
Share on other sites
Aires

Hi,

Just curious if you have jetpack activated I remember having a similar issue where jetpack made the header and the template section not line up correctly. 


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
appappnost

Hi Aires - Thanks for your reply.

 

Nope. I just have DMS Professional Tools plugin activated right now ... 

 

So - that isn't the culprit ...

Share this post


Link to post
Share on other sites
Danny

HI,

 

You can't just add width XXX !important that wont work. The issue is you have added a border, which is added outside of the element area, so you have two choices.

 

1. You can either replace border with box-shadow or outline

2. Continue to use border but use it in conjunction with

 

box-sizing: border-box

 

This will restrict the border to stay inside the element area and not outside of it, like so:

 

http://d.pr/i/FWWJ

 

Code used for the image above:

 

.main-box {
background-color: #000;
border-style: solid;
border-width: 10px;
border-color: #777;
box-sizing: border-box;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
appappnost

Hey Danny -

 

Thanks for the code.

 

I added it into my custom CSS - and - it's not doing anything ...

 

I then went into "Inspect Element" in Chrome's web tools - and - the code that I added - and that was saved - isn't showing up in there ...

 

I'm flummoxed. I can see the correct code (your code) in the code editor - but - it isn't showing up when published ...

 

Any ideas?

Share this post


Link to post
Share on other sites
Danny

See my response to your other topic, as its most likely related to this.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

×