Jump to content

Archived

This topic is now archived and is closed to further replies.

clinton4

Unable to set filesystem credentials?

Recommended Posts

clinton4    5
clinton4

Hi,

 

Why do i get the following error message when i enable DMS debug.

 

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials

I don't understand what the problem is? How do i fix this?

Share this post


Link to post
Share on other sites
clinton4    5
clinton4

Hmm.. So the problem is that DMS wants to get direct file access as my website user, but since uploads/pagelines was created by another user (apache), it cannot get write access?

 

If that is the case, why do DMS need direct file access? Why cant DMS write files as any other wordpress plugin would?

Share this post


Link to post
Share on other sites
Simon    247
Simon

Hmm.. So the problem is that DMS wants to get direct file access as my website user, but since uploads/pagelines was created by another user (apache), it cannot get write access?

 

If that is the case, why do DMS need direct file access? Why cant DMS write files as any other wordpress plugin would?

First of all DMS is not a plugin.

To get a 'theme' in the WordPress REPO you have to follow certain rules, one of which is that you HAVE to use the WordPress FileSystem API.

 

'any other plugin' would probably simply use file_put_contents() and file_get_contents(), these functions are not allowed to be used in a theme.

 

So, DMS is using the native WordPress File handling system to write a file, but your funky permissions are not allowing that.

 

Do you normally need to put in FTP credentials when you install/update a plugin/theme?

Share this post


Link to post
Share on other sites
clinton4    5
clinton4

I see. So what are my options to get this working them?

 

i run my own linux server

Share this post


Link to post
Share on other sites
Simon    247
Simon

I see. So what are my options to get this working them?

i run my own linux server


Which docs did you follow when you setup apache and php?


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

×