Jump to content

Archived

This topic is now archived and is closed to further replies.

alisamski

custom css not holding

Recommended Posts

alisamski

Today, my custom CSS is not holding upon refresh. Flushed Cache. Checked topics here on forum...and found no answers.

 

Here is the css that I need to apply: Shows upon save.. and disappears.

_____________________________

.pl-content {
background: rgba(250, 250, 250, 0.8);
}
#header .pl-content {
background: rgba(0, 0, 0, 0);
}
#navbar .pl-content {
background: rgba(0, 0, 0, 0);
}
#footer .pl-content {
background: rgba(250, 250, 250, 0.8);
}

 

____________

Suggestions welcomed.

 

 

Thanks.

 

http://bit.ly/1cejKbz

Share this post


Link to post
Share on other sites
greenfly

HI alisamski

 

If you could create an admin level account for your site and send the credentials to hello @ pagelines dot com - along with a link to this forum topic in the email i will jump on and take a look for you. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly

Hi there 

The CSS you entered is still there on your site in the Custom CSS area http://d.pr/i/L6FG - however - it doesn't look as though you have pressed save. Are you making sure the light is green on the DMS visual editor before you refresh . 

 

You may have to click out of the CSS area and then click back into this area again to make sure the entries you made take effect. This is a known bug for the moment that will hopefully be resolved in the next iteration of DMS.

 

i made sure the light was green and changes to Custom CSS stuck this time 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
alisamski

I've saved in every configuration possible... and the custom css is still not working... or at least I'm not seeing it..

 

if you go to the inside pages.. not the fron tpage... each area has a transparent white behind the content..

Share this post


Link to post
Share on other sites
greenfly

do you mean (for example) this transparent white behind the 'Our Specialities' area: http://d.pr/i/75zW


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
alisamski

Yes... and the below areas...

 

it is not showing

 

pl-content {
background: rgba(250, 250, 250, 0.8);
}
#header .pl-content {
background: rgba(0, 0, 0, 0);
}
#navbar .pl-content {
background: rgba(0, 0, 0, 0);
}
#footer .pl-content {
background: rgba(250, 250, 250, 0.8);
}

Share this post


Link to post
Share on other sites
greenfly

this only shows when your are logged in and accessing the visual editor. it is not present otherwise - i.e. not present to non-admin visitors

 

does this make sense? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
alisamski

No I do not mean  activating the area...

so the css does not work

 

http://bit.ly/1bfqr71

 

the css saves and then it does not hold. So the content area has a transparent white background around it.

Share this post


Link to post
Share on other sites
James B

Hi there,

 

Ok something is definitely off there. Logged into your site to test, no css seemed to be sticking at all, so in testing removed all your css and tried a basic change, didn't take affect still showed all the stuff I'd just removed. Kept on going, a little while later, change took affect. Set back with original css and again nothing took. This leads me to think that the host could be caching? I'd check with them to see if they cache any files their end.

 

For the time being, as the original css wouldn't go back in (leaving your site unstyled) I have added the code in to the base themes style.css which override whats in the css editor. So now it's showing.

 

I will speak to our developer to see what could be causing this, but I'd def say check with the host as well in the interim.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
alisamski

thanks will do... its a client site... so will find out (GoDaddy) what is going on.

Share this post


Link to post
Share on other sites
James B

Just to update we've had another case where something similar is happening and they are also on godaddy, so be interesting to see what they say. If we hear back on the other case I'll post the comments in this thread too. Core team are aware.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
alisamski

Waiting to hear what type of servers they have this on... if we have to go to GoDaddy for a client, we usually get at least a Deluxe Host Acct. Linux  with CPanel..

This client has a very old website on these servers... so we'll see and will post..

 

Thanks

Share this post


Link to post
Share on other sites
paul_t

To confirm, I've had this problem to. Using the LESS Save Button on the front end of the Pagelines Interface made it stick, but that sort of negates the point of having the custom box in the DMS editor. 

Share this post


Link to post
Share on other sites
James B

The Css/Less fallback in the Pagelines tab in the wp admin area is a fix for if the dms editor isn't working correctly. When saving your code in the css/less panel in the editor, make sure you click elsewhere in the panel to see the saving icon spin in the top right hand corner of the editor, once it's finished saving, publish and check if the css has saved. If it hasn't and the panel is clear but saving in the fall back area, it could be a plugin conflict (the dms editor is jquery based so some plugins can break it) try disabling the plugins on your site and reattempting the css changes to see if this is the cause.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
alisamski

Client is on hold until he finishes checking the site... so I will go thru again and see if I can apply the above tips... until then..

thank you .. and will like to keep this open until I finish up..

Share this post


Link to post
Share on other sites
Danny

OK, as James mentioned above, there is currently an issue in 1.4 where some users encounter an error in saving there changes, this related to custom CSS/LESS, settings and section setting changes.

 

The issue has been fixed in an upcoming patch, in the meantime, what you can do is this:

 

1. When you add custom CSS/LESS or make a change to a setting.

2. Before clicking the publish button, do the following:

A ) For CSS/LESS, move your mouse cursor to outside of the DMS editor and then click.

B ) For Settings and Section Settings, move your mouse cursor to a different option field and click inside of it.

3. This should now trigger the Saving Progression, which you can confirm by looking next to the Publish button.

4. *Once this Saving has completed, click publish and your settings and custom CSS/LESS should now take effect.

 

* If your custom CSS/LESS doesn't take effect after this, then you either have one of the following issues.

 

1. Your custom CSS isn't correct i.e. is either invalid or isn't targeting the element correctly.

2. You have a cache or other plugin causing a conflict.

3. Your host is using a cache system which is preventing your CSS/LESS to take effect.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
×