Jump to content

Archived

This topic is now archived and is closed to further replies.

tpldrew

Which File Generates the CSS - Need to tell Caching Which File to Let Pass Through

Recommended Posts

tpldrew

I've been suffering a number of issues (detailed elsewhere) with data disappearing on servers using heavy caching to serve up Wordpress. The folks at WPEngine are helping fix this issue so others with DMS installed can benefit.

 

We've narrowed down the issue, but need help identifying which file gets hit directly to generate the CSS.

 

If we can tell them this their team can let it pass through the cache and load.

 

Can anyone help with this. I'm in a chat with the cache team at WPEngine right now.

Thanks,

Andrew

Share this post


Link to post
Share on other sites
Simon

The css is written to a static file in the uploads folder. ive replied to one or two of your other threads.

 

Please try and keep this all in one place.

Share this post


Link to post
Share on other sites
tpldrew

Sorry simon. I thought this was a better way to handle this.

I'm nearing the point of giving up on fixing this.

 

I'm at wits end without any idea how to proceed.

 

What writes the CSS to the uploads folder? That's the question maybe?

 

- Andrew

Share this post


Link to post
Share on other sites
tpldrew

Simon,

 

Here's the use case and problem:

 

  • User Status: Logged In
  • Working in DMS Editor the site looks fine, everything seems to be working as I add, edit, or update items, modules and text on the page. Here's what it looks like http://i.imgur.com/AjS818f.png
  • I Publish the page and refresh a second browser (user status: NOT logged in) where the site is completely styleless. Here's what that looks like: http://i.imgur.com/C458MEc.png
  • I Purge the Cache and refresh the front end and the site is back to normal.

I've spent four hours troubleshooting this with the team at WPEngine and they are trying to help. 

 

Do you have any questions about the problem?

- Andrew

Share this post


Link to post
Share on other sites
Simon
You are editing in the production site.

They cache the page when you click save a new CSS file is created and the old one deleted

You see the old page with the old URL until you clear their cache

Ask them if there is a way to disable the caching on the production site so you can make changes there and not in staging


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites
tpldrew

Simon,

I've asked them if they can disable the cache, unfortunately not.

Also, I'm NOT making changes on the staging site. I'm making the updates on the production site.

What they've asked me to find out what forces the re-write of the css file.

That way they said they can make sure this executes.

Does that help?

- Andrew

Share this post


Link to post
Share on other sites
Simon

Its ok, i'll try to make my reply more clear.

 

You are making changes o the production site, the production site is cached.

 

When you click save dms creates a new css file using all the settings.. the css file is saved to the uploads folder.

 

If you look at the css files url you will see it has a timestamp, this is so CDN's, browsers etc always get the latest file.

 

WPE is caching the page, so when you click sav and refresh.. you are looking at the cached page and he url for the css is now broken, because the url changed when you clicked save.

 

There *might* be a way we could hack the code to never write a file on save, or to always use the same url but then if you changed a colour or a width for example... your end users would never see the change..

Share this post


Link to post
Share on other sites
tpldrew

Simon,

Thank you. That's helpful.

Let me ask the WPEngine folks if they can help me with that information.

- Andrew

Share this post


Link to post
Share on other sites
tpldrew

Simon,

Unfortunately, WPEngine can't help with that.

Everytime I hit publish I have to Purge the Cache...

 

I'm going to have to move on without a real solution to this on either end.

Thanks though.

- Andrew

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×