Jump to content

Archived

This topic is now archived and is closed to further replies.

MissT

Slider Revolution Plugin

Recommended Posts

MissT

Hi there,

 

I'm having a problem getting the Slider Revolution plugin to work with DMS - I've seen it on other DMS sites so I know it will work with DMS.

 

I'm getting a grey area where the slider should be but no content is displayed - on the plugin support site it says...

 

“The Revolution Slider is not showing up. Instead I only see a grey box. What is happening?”

The theme you are using is breaking the Revolution Slider plugin and wil break certain other plugins too. This is a very well known bug in the WordPress theme community and should be gone by now. Please contact your Theme Author who should fix his theme with this article about his bug: http://pippinsplugins.com/never-remove-the-default-the_content-filters-in-themes/ If the theme author does fix his theme a quick workaround would be to use the [raw] shortcode wrapped around our revslider shortcode. Example: [raw][revslider yourbanner][/raw]

 

http://themepunch.ticksy.com/faq/388

 

I've tried the [raw] shortcode but that doesn't work.

 

I'm using WP 3.6.1 DMS 1.1.4. Only plugin active is the Silder Revolution plugin.

 

I'm using one of the plugins test sliders not one I've created.

 

Can send you the URL privately.

 

Many thanks in advance.

 

 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

How are you adding the Slider to your page ?

[raw] or [pl_raw] will not work on a TextBox or MediaBox sections.

 

Have you tried disabling all other plugins and see if this resolves your issue. We have other users who are using the Revolution Slider plugin along with the FullBox section and have no issues.

 

You can get FullBox here - https://github.com/pagelines/DMS/issues/537


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MissT

It's a shortcode in the page content. Already said there is only the slider revolution plugin installed.

 

Will try fullbox.

 

Thanks Danny.

Share this post


Link to post
Share on other sites
MissT

I've installed fullbox added it to the page and added the shortcode for the slider in the Text Content area of fullbox. Nothing happens - worse than when it's in the post content of a page.

Share this post


Link to post
Share on other sites
Danny

Sorry add the shortcode to the TextBox title field, users have found that this resolve the issue.

The problem is related to the shortcode itself, the TextBox section allows basic shortcodes and uses the do_shortcode() function on the text area option. Ideally, for things like sliders, you should either use the WP content editor or a hook.

When I tested this plugin for a user, there was no issue(s) using the shortcode on the Wordpress content editor and it viewed as intended when previewing the page I added it too. If you're still having issues, it has to be related to something you have added on your site such as custom CSS or scripts.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MissT

Yes that's better with the shortcode in the title.  Still looks the same as it did in the page content though.  I'm beginning to wonder if the content from the example sliders hasn't fully copied over when I installed the plugin and then imported the examples.

 

There is almost nothing in the site - not much additional CSS or scripts - its my base child theme.

 

I'll add a new slider and see if that shows up.

 

Thanks Danny.

Share this post


Link to post
Share on other sites
Danny

To be totally honest, when I tested the plugin I never tried the default content. There were already sliders created by the user, I would recommend creating your own sliders and see if the problem persists.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MissT

Copied one of the examples and it has now appeared. The images from the examples definately haven't come across for some reason.

 

Will add my own now.

 

Thanks again Danny! :)

Share this post


Link to post
Share on other sites
Danny

OK, happy to hear the issue has been resolved and thank you for informing us.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×