Jump to content

Archived

This topic is now archived and is closed to further replies.

canadiangazelles

DMS update results in blank site

Recommended Posts

canadiangazelles

Hi, 

 

I wasn't sure who to correspond with about this so I'm posting to the forum for guidance.

 

Whenever I update DMS from 1.0.3 to 1.1.4, I get a resulting blank page, meaning that when I type in the address of my site (http://hti.flywheelsites.com), I don't see a 404 page but simply a blank one. Trying to login to wp-admin also results in a blank page. Nothing works. I'm not sure how to even probe this to try to understand where exactly the issue is in the new update. Thankfully, I've just updated the site to the old DMS, in the meantime. I've also turned on/off every plugin individually (including the password protect one) and no luck with getting the site to work.

 

 I'm currently running the latest version of WordPress and I have the following plug-ins installed:

Accordy Slider
 


 

Select Better iBoxes Better iBoxes
 
Select Collapser Collapser
 
Select Content Copyright Content Copyright
 
Select Custom sidebars Custom sidebars
 
Select DepthCharge Section DepthCharge Section
 
Select DMS Breadcrumb NavXT DMS Breadcrumb NavXT
 
Select Flowy Flowy
 
Select Footer Extras DMS  
 
Select Hooker Hooker
 
Select Ninja Forms Ninja Forms
 
Select Pagelines Legacy Sections Pagelines Legacy Sections
 
Select Page Links To Page Links To
 
Select Password Protected Password Protected
 
Select PostPins PostPins
 
Select Salebar Salebar
 
Select Share Me Share Me
 
Select Slabtext Slabtext
 
Select Visual Form Builder Visual Form Builder

 

 

 

Any help would be very much appreciated.

 

Thanks in advance,

 

Rick

Share this post


Link to post
Share on other sites
Simon

Enable WP_DEBUG, flywheel have a switch under advanced settings.

 

A blank page is 99% of the time a PHP fatal error.

Share this post


Link to post
Share on other sites
canadiangazelles

Thanks so much Simon. I'm going to wait until tomorrow so that Flywheel backs up the site as it is (I don't know how to manually engage the backup process in flywheel); then I'll activate and the site will likely get bricked then and I'll be able to restore with all of the plug-ins updated, except for DMS. All of my previous restore versions have about 12 plug-ins and a couple themes that aren't updated (including collapser, which I had to update manually), so I'll report back tomorrow. 

 

Thanks so much!

Share this post


Link to post
Share on other sites
canadiangazelles

Hi Simon, 

 

Here's what I see; any input would be much appreciated.

 

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /www/wp-includes/wp-db.php on line 1142 Strict Standards: Declaration of etcDepthCharge::section_head() should be compatible with PageLinesSection::section_head() in /www/wp-content/plugins/depthcharge/sections/depthcharge/section.php on line 0 Notice: register_tab is deprecated since version 1.1 of PageLines DMS! Use an alternative as PageLinesMetaPanel has been removed from core DMS. See this issue for more details and possible solutions. instead. in /www/wp-content/themes/dms/includes/deprecated.php on line 272 Notice: register_tab is deprecated since version 1.1 of PageLines DMS! Use an alternative as PageLinesMetaPanel has been removed from core DMS. See this issue for more details and possible solutions. instead. in /www/wp-content/themes/dms/includes/deprecated.php on line 272 Fatal error: Call to undefined function pagelines_register_sidebar() in /www/wp-content/plugins/pagelines-legacy-sections/sections/morefoot/section.php on line 33

Share this post


Link to post
Share on other sites
Danny

Hi,

 

The PageLines legacy sections are no longer available in DMS 1.1.4, as they're deprecated, so you will need to remove the legacy plugin. Also, you should probably update your sections to the latest version. Judging from your error its most likely you have a few updates for some sections.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
canadiangazelles

Many thanks! I can now see the main page but the DMS loading image keeps looping. I can, however, now access the backend of WordPress. I went through the troubleshooting guide but no luck. Any advice? Many thanks again.

Share this post


Link to post
Share on other sites
Danny

Infinite loading issue is related to JavaScript most likely therefore, its possible that something on your page such as a custom script is causing the issue. I would remove all custom scripts, CSS and disable all plugins and third party sections, then see if this resolves your issue.

 

I have just upgraded a test site from DMS version 1.0.3 to 1.1.4 and have no such issue, so it has to be related to something you have installed or added.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
canadiangazelles

Thanks, Danny. I'm going to have to set aside a solid stretch of time to go through this then. I've reverted back to the former upgrade again and will continue with that version of pagelines for now as it runs everything fine. I'll either do the one by one unloading of each plugin and javascript or just hope that the next version of PL will automagically fix everything :) 

Many thanks for your help.

Share this post


Link to post
Share on other sites
Danny

OK, well I don't think the next update will resolve your issue, especially when you already have an infinite spinning loading wheel, which is likely to be related to either plugins, out of date sections or javaScript you have added yourself.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
canadiangazelles

Point well taken, Danny. I'll follow up and message back if any issues. Thanks again.

Share this post


Link to post
Share on other sites

×