Jump to content

Archived

This topic is now archived and is closed to further replies.

lexlex88

JS query causing slow page speed performance

Recommended Posts

lexlex88

Hi, 

 

I've been struggling with optimizing my site speed for a few days. I ultimately moved from shared hosting to DV, and although I now have a lower google-pagespeed rating, my site is actually faster and much more responsive. Same thing on tools.pingdom.com, I went from a 91 to an 81, but the site is still faster than it was before. 

 

Anyway, I found the DMS js scripts in the attached screenshot are slowing me down, is there anyway to suppress them? Are they necessary, can I remove them? 

 

parallax

pl.common

bootstrap

easing

fitvids

resize

viewport

waypoints

migrate

 

I could sacrifice the parallax and animations at least for speed if thats the case, but I'm sure theres a way to keep all these and optimize the performance. 

 

Any help would be greatly appreciated.

 

Site in question is: designsqr.com

 

Thanks!

Share this post


Link to post
Share on other sites
Danny

HI,

 

What do you mean by DV ?

 

Also, you can't suppress the DMS scripts otherwise DMS will no longer function. In regards to them actually slowing your site, I don't how this can be as I have no issue with page speed on my FlyWheel test site or my Digital Ocean test site.

 

Therefore, its most likely either your server configuration or you have other scripts/plugins causing the issue.

 

From what I can see you have no cache plugin or CDN active, see our optimize documentation for assistance - http://docs.pagelines.com/advanced/optimize-load-time


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

No problem, happy to hear your issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      Looking at the slow_errors log of WordPress, I have noticed that Pagelines is #1. The site in question is michaelkummer.com  - see
      Michael Kummer Information -- 96752
      --------------------------------------------------
      slow_errors: 4518
      slow_errors_common: [pool site-96752] script_filename = /www//wp-admin/admin-ajax.php +++ dump failed
      slow_errors_common_total: 372
      slow_errors_common_themes_and_plugins: /wp-content/plugins/pl-platform: 1246
      /wp-content/themes/pl-framework: 746
      My hoster is Flywheel is they are usually pretty good when it comes to performance. So I was wondering if anyone else has experienced those issues and if there are any solutions.
      Thanks
      Michael
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
×