Jump to content

Archived

This topic is now archived and is closed to further replies.

radroz

Internet Explorer problems

Recommended Posts

radroz

Hey guys, I've got a problem with Internet Explorer on this site:

 

http://imaginemediasolutions.com/trinity

 

The client's computer has it coming up like the attached image in IE 8, on separate computers. I can't re-create the problem with Browserstacks, so I have no clue how to diagnose the issue.

 

I deactivated all plugins, and the problem persists.

 

I activated the specific browser CSS in the Pro plugin, but for some reason, on her computer it's not working right. She's very concerned that it will show up that way for others, and nothing I say can reassure her.

 

Frankly, we need to have some way to better support IE8 since it's still in use by so many. Or at least know which sections don't work in IE8 so we don't use them. 

 

I'm using the standard NavBar. 

 

Share this post


Link to post
Share on other sites
James B

Hi

 

There's no image attached :-)


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
radroz

Edited. Oops.

Share this post


Link to post
Share on other sites
radroz

Okay, Simon — I need to know what's causing the problem. What can I look for? No matter what I do, her IE8 will not change from what I posted. Even when I disable all plugins.

I've seen this happen before. My custom CSS is loading, but the rest of the DMS is just... wonky. 

I haven't been able to reproduce this on several browser shot applications. Since I'm using a Mac, I can't reproduce it here either. But her computer is showing it, and she's having a fit. I need to know what kind of troubleshooting I can do to fix the problem or isolate it. 

Again, I disabled all plugins, and it didn't fix it. Using the Pro plugin doesn't fix it. What else can I look for? I emptied the cache. 

Share this post


Link to post
Share on other sites
Simon

Right, installed virtualbox, the windows XP, then updated to IE8..

 

here is a link of the page in ie8

http://screencast.com/t/ZMmOxSErUeG5

 

probably your user is running comparability mode in ie8 without knowing it. you can help to disable it by adding this to the header scripts area:

<meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=EDGE" />

Share this post


Link to post
Share on other sites
radroz

Did I put it in the right place?

Share this post


Link to post
Share on other sites
Simon

Did I put it in the right place?

Looks like it

Share this post


Link to post
Share on other sites
radroz

Hi Simon, I used Hooker to force the script higher into the head. Simply adding it to the header scripts area does NOT work. Apparently it has to be as close to being the first script as possible. 

I was able to reproduce her error in Compatibility mode (thanks Browserstack) and the new script you provided — when placed in the wp_head hook, works perfectly.

 

Thank you.

Share this post


Link to post
Share on other sites
Simon

Hi Simon, I used Hooker to force the script higher into the head. Simply adding it to the header scripts area does NOT work. Apparently it has to be as close to being the first script as possible. 

I was able to reproduce her error in Compatibility mode (thanks Browserstack) and the new script you provided — when placed in the wp_head hook, works perfectly.

 

Thank you.

Interesting, thats good to know

Share this post


Link to post
Share on other sites
circ2013

Hello Simon and Radroz,

 

I have now had this issue on two of my clients sites.  In both cases, they were viewing their sites in IE using Compatability Mode (becasue they have intranet's that only work in older IE versions).

 

I have temporarily added this  <meta http-equiv="X-UA-Compatible" content="IE=edge"> to the header.php file and it has resolved the issue, but I know that it isn't a permanent fix, as it will get overwritten if I take an update. 

 

Is there a recommended way to do this so that it doesn't get removed with updates?

 

I am not a php guru, but could I do something like the following in my child themes functions.php?

 

add_action ('wp_head' , 'ie_compatability_mode_fix');

   function ie_compatability_mode_fix ( ) {

   echo '<meta http-equiv="X-UA-Compatible" content="IE=edge">';

   }

 

Would this put it in the correct place (high enough in the code)?

 

Or is there better method such as creating a version of the header.php that resides in my child theme?

 

Thanks,

Scott

 

 

 

 

Share this post


Link to post
Share on other sites
Simon

Your code should work fine. As long as its in the HEAD of the page.

Share this post


Link to post
Share on other sites

×