Jump to content

Archived

This topic is now archived and is closed to further replies.

nfp1900

margin-top CSS not having the desired effect to align textboxes

Recommended Posts

nfp1900    29
nfp1900

Am just finishing this site but I'm having some issues getting the top three boxes to align. There are three columns each with a text box. 

 

First is a box with html/custom class, second a shortcode for the Rev slider and third html for the twitter feed.

 

http://citywomen.org.gridhosted.co.uk/

 

.welcome-text {
  h2 {color:#000;}
  p {color:#000;}
  background-color: #ceba95;
border-radius: 4px;
    box-shadow: 0px 0px 0px 2px #d8dbdb;
    opacity:0.8;
  margin-top:28px;
}
 

 

In Chrome the three boxes align at the top using  margin-top: XXpx; but in Safari and Firefox it doesn't seem to matter. 

 

I don't care how the boxes reflow at the bottom, thats fine, I just need to neaten up the top. Should I be using something else?

 

Thanks

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

The issue is that the TextBox currently has an issue where it appears to adding a markup that isn't supposed to be there. You can see the issue here - https://github.com/pagelines/DMS/issues/580

I would recommend switching the TextBoxes with MediaBox or you can use CSS to push to the Twitter widget down like so - http://d.pr/i/VodD

 

#textboxume9wb {
margin-top: 20px;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

is this a pagelines issue with the text box or some dodgy code I've got in there? 

Share this post


Link to post
Share on other sites
James B    436
James B

It's looks like a pagelines issue with the textbox, Danny has reported on the tracker for the core team to look into.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

The mediabox isn't accepting the shortcode I need for the slider in the embed/html or the title field. Are shortcodes meant to work in the mediabox?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, yes they should do. I've just tried the pagelines shortcodes in there and a third party form shortcode and they are rendering. Whats the shortcode you're adding?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      I have been unsuccessfully trying to get my 3-column widgetized footer aligned centered. The widget section itself is aligned left because the alignment appears to be controller the widget's content only. The container that contains the widget section is aligned centered. I have chosen a 3 column layout and I added 3 widgets, assuming they would be aligned centered.
      Any idea of what I may be doing wrong?
      The page is question is: http://www.michaelkummer.com
      Thanks
      Michael
    • Bleuy
      By Bleuy+
      Problem: Full Screen Revslider content runs off the screen on mobile devices (particularly calls to action buttons).  I've used the <br> to break up the text, however the call to action buttons run off the screen.  Therefore without making the fix too technical (and I can see some VERY technical resolutions on here) my client just wants to simple centre justify the text when being viewed on a mobile device.  
      Any ideas on how best to achieve this in a simple, non too technical way?
      Thanks very much in advance
       
    • saur0
      By saur0+
      Hi, I have managed to change the size of the navbar logo to 75px, but I now want to change the size of the font on the menu (20px) and align the menu vertically to the bottom (so it is in line with the bottom of the logo image). I've been playing around with the CSS but can't seem to get it right, if anyone could give me some pointers it would be much appreciated. 
      The site is feltonssolicitors.co.uk if you want to take a look at the source. 
      Thanks, 

       
    • dgsarnow
      By dgsarnow+
      I have a revslider on my homepage and have used the alignment option to put the text on the right. When viewed on my mobile device the text runs off the screen.

      https://www.dropbox.com/s/mqqox99r1hfr8ii/Screenshot_2014-12-11-14-03-08.png?dl=0

      My site is http://HarQen.lisasarnowski.com/home
    • Redita
      By Redita
      Popshot is not working for me. 
      I've configured it using these as settings and haven't touched anything else. NOTHING else. http://forum.pagelines.com/topic/35171-popshot-not-popping-feeling-dumb/?p=218803
       
      When I inspect the code the offset is there, but the 3 images (screenshots of my clients software) are all aligned the same. All plugins were deactivated one by one and nothing was fixed. Cache cleaned every time (I also have an incognito window checking only published stuff).
       
      Debug mode is activated and here's the site:
      http://dialer2.inexusdialer.com/wordpress/
       
      Thanks.
×