Jump to content

Archived

This topic is now archived and is closed to further replies.

massmosaic

Removing "Template" area from single page

Recommended Posts

massmosaic

Hi Pagelines,

 

I'd like to embed a map fullscreen on a page on my website. When I do this, I alway have the small white area up top. (See attached image.) I'd like to remove that white area up top, so the map comes flush with the black header. Can you provide a tip on how to do this??

 

Here's a link to the site: http://rad.mosaicearth.com/mapbox-test/

 

Thank you for any help!

 

 

Share this post


Link to post
Share on other sites
James B

Hi there, on that page there's padding-top applied to the classes below which you can remove. That will give this result - http://screencast.com/t/PenekPt1sO9

 

pl-area-wrap  pl-bg-cover

 

Then the rest of the white is coming from padding applied to another class. Remove this to get it completely flush - http://screencast.com/t/5x7k7oNYNfqy

 

.pl-section-pad

 

You can use the page-id prefix to your css to make sure any changes you apply on those classes only affect that page. The page id can be found at the top of the inspection panel for that page, for example yours would be page-id-641 - http://screencast.com/t/r62jGZhtgIFD


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
massmosaic

Hi James,

 

Thank you for the help with this CSS. I spent the last 2 weeks studying up so I can make these changes and got stuck.

 

I've added the following code to my pagelines Custom CSS/LESS entry box: 

 

.page-id-738 .pl-section-pad {padding: 0px 0px 0px 0px;}

 

(Note the page id is now 738)

 

Although I understand that .pl-section-pad is the correct area to target, when changing to 0px padding (in chrome dev tools) nothing happens. I've tried this with and without the page id in there to check and that padding will not be removed! Is there something obvious I'm missing here?

 

See attached screenshot for reference.

 

The url of this page is rad.mosaicearth.com

 

Thanks very much.

 

 

Share this post


Link to post
Share on other sites
Danny

Can you provide a link to the page that contains the map, so I can try and remove the padding myself please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

The map is full width, so has the issue been resolved ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
massmosaic

No, it's always been full width.

 

Plz see the attached image... I'm just trying to remove the .pl-section-pad ... when setting padding to 0px, it still shows up.

Share this post


Link to post
Share on other sites
Danny

That space isn't coming from anything in DMS, its related to the plugin Sabai Directory, you will need to alter this CSS:

 

sabai-directory-nav {
margin: 0 0 1em;
}
 

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
massmosaic

Cheers, thanks so much Danny.

 

Ok, thread solved :)

Share this post


Link to post
Share on other sites

  • Similar Content

    • Paul
      By Paul+
      I was surprised to see I had no menu today - out of the blue - its actually moved to the bottom of the page!  After hours of fiddling and disabling every single plugin, leaving just plagelines the issue is still present.  See video for a basic text box - I moved it into the head and it jumps to the bottom and shows just above the footer but below the main content.  I have a temp fix by placing the menu into the first row on the main content but it does mean other than my home page, all other pages have no menu.  A quick fix is very urgent for this bug.
      https://thelaptopfixers.com
       
       
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • flourishdesignstudio
      By flourishdesignstudio+
      Hello,
      I have an older site that was built using PageLines several years ago (prior to the release of DMS). I wanted to leverage some of the power of your new PL5 plugin but the theme prevents be from adding any generated custom sidebars to the theme (through the drag and drop interface) and does not allow me to add any PL5 sections/containers/etc to the header or footer. Is there any way to easily override that or am I stuck only using PL5 in the content areas of the site?
      Thanks so much for the help!
    • JP
      By JP+
      Hello,
      How can you set the translations with platform5, the parts that are not in pages or posts? Texts and images…
    • romanondrasek
      By romanondrasek+
      hi all, I have some trouble using PL5 on my site. 
      I used plugins for event calendar (event on) and plugin (timetable responsive scheduler for WP) for schedule (classes) in the gym.
      The problem is, that post from this 2 plugins are shown without menu in header and footer. (I setup header and footer) in the page editor for all type of page. 
      When I create a lesson, it creates posts with slug (I have a slug "lekce" & event for events).
      I try to edit the post with PL editor, but editor is not opening on the post.

      Do you have some idea where should be some problem? Thanx so much.
      here are links for the sites :
      site with schedule :
      http://www.myfit.cz/rozvrh/
      site of one of the class (pilates)
      http://www.myfit.cz/lekce/pilates/
      site with calendar :
      http://www.myfit.cz/kalendar/
      7 side with one event from the calendar :
      http://www.myfit.cz/event/pilates-instruktor-akreditovana-licence/?ri=1
      when I have my site on DMS2 it was working :-(
       
       
×