Jump to content

Archived

This topic is now archived and is closed to further replies.

brightonkeller

Sidebar Disappeared and Column Span defaulting to 100%

Recommended Posts

brightonkeller

This issue is slightly specific to my website, but hopefully the issue and it's subsequent problem-solving can be helpful for others!

Problem summary: my sidebar (next to my span 8 "main column" with postloop included) is NOT visible 

Here is what is happening: 
1. I add a new column with a width of Span-4 (via the increase/decrease options on the column) 
2. I add a media box, text box, and wedigetized "Primary Sidebar" inside the span-4 column 
3. Refresh and Publish 
4. Add a class to the span-4 column (I don't think this makes a difference though - because I have tried it both ways) 
5. Refresh and Publish 
6. The sidebar now moved to the bottom of the content section (below postloop) and turns into a FULL-width section with 100% width that I am not able to edit (see image 1)

I tried to upload my screenshots, but it wouldn't let me. 

Share this post


Link to post
Share on other sites
greenfly

The issue appears to be with your Custom CSS - you have a number of line of code that are adding padding to the span8 column. 

 

You have given the Span8 column the following Classes  - .maincolumn & .rightline

 

The CSS for these classes is as follows 

.maincolumn {max-width: 566px; padding-right: 50px; margin:auto;}
.rightline {border-right: 2px solid @color10; padding-right: 25px;}

This is adding 75px padding to the right of the Span8 column and pushing the span4 underneath the span8 as there is not enough room for the span4 column. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
brightonkeller

I actually tried a few different classes. I added "sidebar", tried that....and then I added "sidebar1".....and I even tried random things too. 

But I dont think it was adding the class that made a difference! 

Share this post


Link to post
Share on other sites
brightonkeller

But I've had this CSS for months now and it never seemed to be an issue.....

Share this post


Link to post
Share on other sites
greenfly

To test i commented out the CSS and it worked. 

 

If you add 75px of padding to the right of your column it will push the sidebar over the width of the page. 

 

You can test this by removing all your CSS and try adding the column with span4 again. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

×