Jump to content

Archived

This topic is now archived and is closed to further replies.

antonyw

style class problem

Recommended Posts

antonyw

Hi, I have tried to create the following class to control the font used in a text box..... but its not working.... please can anyone help

 

[.traj

{
font-family: trajanproreg;
}]
 
 
(ive already created the font-face code for my new font etc etc)

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Please refrain from creating multiple topics when you have already asked this question else where.

The code you have provided above isn't valid as far as I can tell, if you want to know how to implement custom fonts see our docs here - http://docs.pagelines.com/tutorials/adding-custom-fonts

Also, for using the styling classes, you add your custom CSS to the Custom CSS editor, then add the class name to the styling classes field, see here for more information - http://docs.pagelines.com/tutorials/section-area-styling


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
antonyw

Thanks for your feedback and sorry about the duplicate questions... just getting a bit twitchy about a deadline - wont happen again...

 

I have already seen both your links and they were great for adding fonts and setting some style elements... but i cant seem to make them work with actual fonts

 

The code i added above was my custom CSS... I was then going to add this class name to the styling classes field.... it didnt work.

 

'trajanproreg' is the name of my new font... which i added to the custom css and uploaded and that bit works

 

Thanks again for your help - really appreciate it

Share this post


Link to post
Share on other sites
Danny

Yeah you only add the class name to the styling field, not the actually CSS.

 

What do you mean you can't seem to make them work with actual fonts ?

You just follow the instructions on the adding custom fonts doc. If it isn't working then post your CSS and also a link to where you got the font font, its most likely you haven't added the font correctly, the path isn't correct in the fontface CSS or you haven't followed the instructions provided by the font itself.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
antonyw
I understand the bit about adding only the class name in the style classes box. I will double check my custom CSS etc and see what happens

Share this post


Link to post
Share on other sites
greenfly

Please let us know how you get on 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
antonyw
Bingo sorted! My style class definition was wrong and my font-face definition was incomplete (still is need to fix that bit tomorrow) thanks for your help with that

Share this post


Link to post
Share on other sites
greenfly

Thank for letting us know you got it sorted :) 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

×