Jump to content

Archived

This topic is now archived and is closed to further replies.

antonella

Changes to CSS custom style sheet not showing on site

Recommended Posts

antonella

Hello,
 
I am using a custom stylesheet for my pagelines (framework) child theme. Some changes take effect immediately, and some never do. Why is this happening. Is there something overriding my css? Shouldn't the css in the custom sheet override everything else?
 
For example, I am trying to restyle the hero box on this page. Via firebug I found the code and the changes worked within firebug. When I add it to my stylesheet, the changes don't appear. I've cleared my cache, tried it in other browsers, etc, to no effect.
 
When I go back and look at firebug, I see that the style is duplicated: the first is I suppose my style, but it comes in empty between the brackets. Then it repeats the original style in full (see attached screenshot).
 
This is the code I want to substitute:
 

.pl-hero-wrap .pl-hero h1 {
    color: #1F2B7B;
    font-size: 24px;
    letter-spacing: -1px;
    line-height: 1;
}

.pl-hero-wrap .pl-hero p {
    color: #555555;
    font-size: 16px;
    font-weight: 200;
    line-height: 1.5em;
    margin: 5.25px 0 21px;
}

.pl-hero-wrap {
    -moz-box-sizing: border-box;
    background-color: #F5F5F5;
    border: 1px solid #FFFFFF;
    border-radius: 0px;
    box-shadow: 0 0 6px rgba(0, 0, 0, 0.2) inset;
    padding: 5%;
}

This has happened several times, randomly, so can't find a consistent pattern to troubleshoot. Any direction would be appreciated.

 

Thanks,

Antonella

 

Share this post


Link to post
Share on other sites
antonella

Hello,

 

I tried using both #page and #site, but it's still not working. Now it's giving me an empty value with the override. For example:

#site .pl-hero-wrap .pl-hero h1 {
}
.pl-hero-wrap .pl-hero h1 {
    color: #10163E;
    font-size: 60px;
    letter-spacing: -1px;
    line-height: 1;
}

Am I doing the override correctly?

Share this post


Link to post
Share on other sites
Danny

I have just looked at your stylesheet and you have the following:

 

http://d.pr/i/eGBR

 

This means you have something causing that format, you will need to correct it. Then your CSS will load correctly.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
antonella

Argh! Okay thanks for the info. Ever since I got my macbook air, have been having problems with those sorts of entities, etc. Works now!

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×