Jump to content

Archived

This topic is now archived and is closed to further replies.

dreamsight

Breaks appearing in forms

Recommended Posts

dreamsight

Hello, I know formidable isn't amazingly compatible with Pagelines, however this new issue has cropped up on a bunch of new sites I've been working on lately where the required field star is pushed onto a new line, thus making the forms look a little odd.

 

had a little browse in css and couldn't find the culprit, any ideas?

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Can you provide a link to the page where the form is please, so I can take a closer look. You will probably want to switch to Twenty Twelve or Thirteen and make sure that its not an issue with the plugin itself.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

From what I can see, this is a plugin issue, as its adding a break before the * when you view your source code. See my screenshot below.

 

http://d.pr/i/b0G8

When I remove it from the code, the Asterisk appears on the same line.

 

http://d.pr/i/qROy

Therefore, in my opinion this is an issue with the plugin, the way to check this is by doing as I mentioned above and switch to another theme such as Twenty Twelve or Thirteen and see if the problem persists, which it should do.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dreamsight

Hi Danny, figured it out, may have jumped the gun on reporting this as an 'issue' - i had added the form to page by dragging a section and then adding the form via textbox, this adds breaks and < p > tags automatically, fixed by simply adding the form code into the phsyical wordpress page and then adding the post/content loop. 

Wouldn't have figured it out without your help anyway, so thanks!

Share this post


Link to post
Share on other sites
Danny

Ok, well you can still use a TextBox, just wrap the forms shortcode with this:

 

[pl_raw]

 

[form shortcode

 

[/pl_raw]

 

The [pl_raw] prevents WP from adding <p>...</p> tags.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dreamsight

even better, thanks Danny 

Share this post


Link to post
Share on other sites
Rob

:)


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dreamsight

hey guys, the [pl_raw] shortcode doesnt seem to work with the Formidable plugin? it stops the form showing altogether.

Share this post


Link to post
Share on other sites
James B

Hi there, the pl_raw shortcode won't work inside a textbox or media box unfortunately, it will just get the box to show 'add your content' etc on the page. You'll need to put it into the main postloop section if you need to use pl_raw.

 

Pl_raw can also only be used once on a page.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
dreamsight

Hi James, thanks for clearing that up. 'best answer' isn't exactly true in that case then.

 

Okay the longer i try working around this the more i realize i need a solution as to how to stop these breaks or p tags being generated in the meda/text boxes on these forms! there's going to be one on every page and using the post/content loop is not an option as the content is already up and everything is in its place.

 

i've checked the plugins and nothing seems to be conflicting.. 

 

http://1028112046.n588565.test.prositehosting.co.uk/fulfilment/flexible-storage/

Share this post


Link to post
Share on other sites
dreamsight

a simple explanation as to why this is happening or a solution would be greatly appreciated.

if it was a problem with the plugin then why has it worked fine in Framework and on the Contentloop?

Share this post


Link to post
Share on other sites
Danny

No sure as to why the plugin is being effected like this. I will report this to our tracker. However, could you try using the Textwidget in a widgetized sidebar and see if that is effected ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dreamsight

Example http://1028112046.n588565.test.prositehosting.co.uk/printing/

 

Breaks and page breaks appear in the code like this...
<input type="hidden" name="frm_action" value="create" /><br />
<input type="hidden" name="form_id" value="10" /><br />
<input type="hidden" name="form_key" value="oejq7n" /></p>
 
Also after virtually every item...
</label><br />
</span><br />
 
 
If we put the form short code in the Post/Content Loop with the WP editor the form is ok and the extra breaks are not added.
 
Any ideas?

Share this post


Link to post
Share on other sites
Danny

Hi

 

How are you adding the form, is it via HTML or a shortcode and in which section ?

Also, don't you already have a topic open regarding this issue ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
James B

What about putting the main page text in the textbox, the form in the postloop, then just saving as it's own template and switching over the sections in the drag and drop so they are in the same position as the current layout?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
James B

admin note: threads merged


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

×