Jump to content

Archived

This topic is now archived and is closed to further replies.

Leonardo da Vinci

How to make the fixed navbar be on the first section?

Recommended Posts

Leonardo da Vinci

Hi guys 

 

How to make the fixed navbar be on the first section not take a space in top of the first section 

I have a Transparent navbar and I'd like to be on the first section and not to takes a space ti top of the first section 

 

Thanks 

 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

I apologise, but I am not entirely sure what you mean, can you go into greater detail and/or provide some screenshots please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
greenfly

HellO Lonardo - could you please provide a sketch of how you want this to appear - it is unclear from your description exactly what you are trying to achieve. If you could put some arrows and annotations on it so we can grasp what you are trying to achieve. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Leonardo da Vinci

Thanks

What I want to do is when i scroll up to the top of the site the navbar got unlike color but when scroll down one scroll the nav bar be Transparent .

thanks

Share this post


Link to post
Share on other sites
greenfly

Have you tried any custom CSS to achieve this? could you give us an example of the code you have tried? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Leonardo da Vinci
.navbar.pl-color-black-trans {
  background-color:rgba(0, 0, 0, 0.498039);
  background-position:initial initial;
  background-repeat:initial initial;
  border-top-color:rgba(0, 0, 0, 0.901961);
  border-top-style:solid;
  border-top-width:1px;
}

Share this post


Link to post
Share on other sites
James B

From reading your initial post it sounds like you want the image to go right under the nav at the top of the page, so the gap is removed. So the navbar goes over the picture straight away. If that is the case, try the below code to remove the space.

 

.fixed-top-pusher {
    height: 0;
}

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Leonardo da Vinci

Thanks a lot James 

 

It's working on firebug only ,but when I put the code in Custom LESS/CSS in DMS , ther is nothing 

please may help 

Thanks

Share this post


Link to post
Share on other sites
James B

Do you mean the code was vanishing from the css/less editor? Try putting in to the fallback editor in the wp admin area.

 

Go to wp admin>Pagelines>css/less fallback and enter the css in there and save. Then check to see if the changes show.

 

If still not working but the css is saving, try adding !important to force it.

 

.fixed-top-pusher {
    height: 0 !important;
}

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Leonardo da Vinci

All of these ways not working but I forget to tell you the the image is RevSlider , please can you check my site , please send me your email to make you an admin.

 

Thanks 

Share this post


Link to post
Share on other sites
Danny

HI,

 

Use the following code, this should resolve the issue.

 

.fixed-top-pusher {
height: 0px !important;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Leonardo da Vinci

Thanks a lot for you James & Danny 

 

It's working now

 

Thanks again

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Leonardo da Vinci

Hey guys 

 

I recently upgrade from DMS 1.1.8 to DMS 2.1.3, every things cool but I have an issue with the navbar, It returns not working as it before with DMS 1.1.8 . 

Please may you help me with this :)

Share this post


Link to post
Share on other sites
Danny

Please create a new topic as this topics question has already been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×