Jump to content


This topic is now archived and is closed to further replies.


Primary website navigation bar does not change its language

Recommended Posts




I am creating an spanish / catalan multilanguage site, and I have a problem with the Primary Website navigation menu, which does not change when clicking on the language flag. It stays with the default language (catalan). I looked in the forum posts but I didn't find anything that could help.


Website URL: s408919052.mialojamiento.es This is a sandbox where I am building the website. Afterwards I will move it to www.educatcastellbisbal.es. If you have a look there, you will find already the website, but it is 1 languange only right now.
Framework Version: I am not sure about this. I guess you mean the theme version. It's 1.4.5
WordPress Version: 3.6.1
Plugins in Use: 
Language related
- Polylang 1.2.3
- WPML flag in menu 1.1
- WPML Flag in Menu Extended 1.2 This one was in use first but since it didn't work I deactivated it, allthough it is still installed. Now using the the WPML flag in menu 1.1 plugin.
Non language related
- Contact form 7 v.3.5.4
- Contact form 7 widget v.1.0
- Facebook v.1.5.3
- Google maps widget v.1.10
- Jetpack for Wordpress.com v.2.5
- Really Simple CAPTCHA v.1.7
Other plugins are installed but not active yet. 
Server/Host: db412100285.db.1and1.com
Screenshots: As you can see on the screenshots, the page and the boxes language change when clcking on the flag, but when I select the spanish version, which you can see with the catalan flag on the menu, the menu language remains in catalan.
I created the whole website without touching at anything on the code. I think this may be a problem with Polylang, but I am not sure about it.
Thanks a lot in advance.

Share this post

Link to post
Share on other sites
James B

Hi there,


I've not used the polylang plugin but it seems to suggest you need to add the languages manually - http://wordpress.org/plugins/polylang/installation/


Have you checked with the plugin author to see if they're able to advise on what could possibly be happening? They have a support thread here - http://wordpress.org/support/plugin/polylang which could help

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post

Link to post
Share on other sites

Thanks for informing us the issue has been resolved, we appreciate it.

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?