Jump to content

Archived

This topic is now archived and is closed to further replies.

bloom1creative

Website speed issue

Recommended Posts

bloom1creative+    3
bloom1creative

Hey guys, sorry to be a pain again.

 

Recently set this site up from MAMP : localbustorbay.com/localbus

 

I believe it to be the host, but would hugely appreciate if somebody could check and confirm it's not something I havn't done optimisation-wise for the DMS.

 

All the LESS is in the style.less and I have the Pro tools plugin running too, and Cloudflare as well and minification.

 

Naturally this speeds it up a hell of a lot, but when the CDN is turned off and we are editing the site live (no cache) I am getting loading times of about 1 minute which is insanely slow for a 1.1mb sized webpage!

 

Thanks guys


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

Where is the site hosted? Impossible for us to tell when your behind a proxy.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Haha you're in Devon too!  It's hosted through Heart Internet if that's any help at all.  You would need Cloudflare turned off to check it effectively?


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well just the server IP would do to run a few tests... 

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Thanks Simon, the IP is 176.32.230.22


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

Not much we can tell really.

 

The site *should* load pretty fast, as the css is cached to file so there isn't any issues there.

 

The best way to speed up a slow site if the problem is TTL is to use a page cache. All cloudflare does is cache dns lookups and pass static stuff like images/css/js etc through a CDN The actual page content though still comes from your server.

 

So, id suggest something like wp super cache, its easy to setup and if its running in .htaccess mode the static pages will load as fast as the web server can deliver them as PHP is never used.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Thanks for help Simon, we tried WP Super cache but the results were still similar, if not the same.

 

We have disabled Cloudflare and related plugins, moved the Nameservers back to our host and disabled WP Super Cache and cleared out the .htaccess file.

 

I have attached a speed test result, and am inclined to think it is our host delayed the site by 8-12 seconds before the site even loads.

 

I really appreciate any help you can offer as I really want to get to the bottom of whats causing the delays  :growl:

http://screencast.com/t/BC1EDPe7X


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

the time to first byte is normally database lag, or general server slowness.

 

If you want me to i'll log in and make sure super-cache is properly configured. If its serving static files that slow too then there is a deffo server bottleneck somewhere.

 

PM me a login if you want.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Thanks for that Simon, have PMed


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

Ok had a quick look, i think half the problem here is that super aggressive 'security' plugin you have installed. 

 

super cache needs rules added to .htaccess, but that plugin wont let it write its rules there, so the cache uses php to server files, which is very slow.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Hmm interesting, I have used that plugin on other sites and they are nothing like as slow as this one, included another much larger site hosted on the same server, with WP Cache installed too.  I will disable the WP Security plugin now and see if that makes any difference - do you have any recommended alternatives then for security plugins for Wordpress?

 

Also, how did you manage to login? haha.  The plugin obviously isn't that good...


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

:ph34r: Ninja powers ;)

 

Yea if you could just stop it hijacking the .htaacess file it would help.

 

As for security plugins ive never seen the need for any.

 

All i use is limit login attempts plugin. Everything else is common sense,like not using the 'admin' account etc. Those plugins are severe overkill, and i bet it wants you to subscribe for something too right?

 

Dont take this the wrong way, im not saying security is overrated, im just saying one massive kitchen sink security plugin is overkill.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Just a side note too Simon, the Wp Super Cache never returned any errors when trying to write to the .htaccess file, we had a green success notification.  The main worry we had was in the Content section where it mentioned that no files have been cached.... :/ 


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

Just a side note too Simon, the Wp Super Cache never returned any errors when trying to write to the .htaccess file, we had a green success notification.  The main worry we had was in the Content section where it mentioned that no files have been cached.... :/ 

Yes it probably IS writing to the htaccess file, but ermagurd security pro is probably rewriting it, probably thinks its doing you a favour too lol

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Haha, ok then, interesting things 'coz you read so much in forums and SOOOO many people adore the Better WP Security one, and I've always found it to be good, but the way you got in so easily and have mentioned your points makes me feel somewhat differently.  So Ive taken the WP Security off, did you manage to check the Super Cache at all mate?  I do appreciate your time.  I assume there isn't much else we could have done wrong with WP Super Cache really?

 

We have launched so many Wordpress sites, a lot on PL 2.0 too, and never really had an issues like this one which is incidentally our first DMS site... I am not by any means trying to blame the DMS, but it's our current anomaly and we can't really help but think that if you see what I mean  :startle: :D

 

Any ideas what might be causing the files not to cache?


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Just for reference dude, here(http://screencast.com/t/NPYeBfyrt1) is the results after removing WP Security and Re-applying WP Super Cache so the .htaccess file is now just 

 

# BEGIN WPSuperCache
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /localbus/
#If you serve pages from behind a proxy you may want to change 'RewriteCond %{HTTPS} on' to something more sensible
AddDefaultCharset UTF-8
RewriteCond %{REQUEST_URI} !^.*[^/]$
RewriteCond %{REQUEST_URI} !^.*//.*$
RewriteCond %{REQUEST_METHOD} !POST
RewriteCond %{QUERY_STRING} !.*=.*
RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTP:Accept-Encoding} gzip
RewriteCond %{HTTPS} on
RewriteCond %{DOCUMENT_ROOT}/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index-https.html.gz -f
RewriteRule ^(.*) "/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index-https.html.gz" [L]


RewriteCond %{REQUEST_URI} !^.*[^/]$
RewriteCond %{REQUEST_URI} !^.*//.*$
RewriteCond %{REQUEST_METHOD} !POST
RewriteCond %{QUERY_STRING} !.*=.*
RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTP:Accept-Encoding} gzip
RewriteCond %{HTTPS} !on
RewriteCond %{DOCUMENT_ROOT}/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index.html.gz -f
RewriteRule ^(.*) "/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index.html.gz" [L]


RewriteCond %{REQUEST_URI} !^.*[^/]$
RewriteCond %{REQUEST_URI} !^.*//.*$
RewriteCond %{REQUEST_METHOD} !POST
RewriteCond %{QUERY_STRING} !.*=.*
RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTPS} on
RewriteCond %{DOCUMENT_ROOT}/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index-https.html -f
RewriteRule ^(.*) "/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index-https.html" [L]


RewriteCond %{REQUEST_URI} !^.*[^/]$
RewriteCond %{REQUEST_URI} !^.*//.*$
RewriteCond %{REQUEST_METHOD} !POST
RewriteCond %{QUERY_STRING} !.*=.*
RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
RewriteCond %{HTTPS} !on
RewriteCond %{DOCUMENT_ROOT}/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index.html -f
RewriteRule ^(.*) "/localbus/wp-content/cache/supercache/%{SERVER_NAME}/localbus/$1/index.html" [L]
</IfModule>


# END WPSuperCache




# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /localbus/index.php [L]
</IfModule>


# END WordPress

Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

is the htaccess file in the right place? you have wp in a folder right?

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

I've never been 100% sure where the .htaccess should go, either in the root or the subfolder, being that I am still referencing the site in a subfolder in the URL.  The last time I tried to use the DMS with the site URL pointing outside the subfolder, when the site files were in a subfolder, I had issues with the DMS functionality - so I had to return the URL and HOME URL back to the subfolder in order for the DMS to function correctly.


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

After trying a static html file on the server we are getting lightning fast loading times, so there is definitely something set up wrong with the DMS php page rendering time. :thumbsd:  So when you went into the WP Cache Settings and backend nothing stood out to you as being calibrated incorrectly? Still having no cached files. Thanks mate


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

Yea i dunno, are the html files being built at all? they should appear in the cache folder.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Yeah the pages appear to be being cached now, and the Cloudflare has been set up correctly.  The site is horrendously slow on DMS but so much faster on the other themes, it's just a shame I'm too late in the day now to be able to redesign the sites on the Wordpress themes to speed them up, the plugins are exactly the same too.

 

The complied CSS seems to not be being found now most times on refresh, but the styles do come in still... On some refreshes though the styles don't load at all and we are presented with the html and front end css from added DMS images, etc.


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

well if your using cloudflare+total cache, when you click save the css url is changed each time, so that has to resync with th cdn etc.

 

Also id really advice against the db and object cache on disk. unless you have an opcode cache like APC/memcached etc its extremly slow.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Thanks buddy,  We are getting big issues at the moment with W3 TC and it having trouble finding the latest 'complied-cc' as it is constantly looking for the url it was when we saved.  I noticed another couple of posts on here about the same issue, but for the DMS there seems to be no simple fix?


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites
Simon    247
Simon

well we use w3 cache on the main site, with a CDN with zero issues.

Share this post


Link to post
Share on other sites
bloom1creative+    3
bloom1creative

Right ok... so it must be our settings.  I'm sure it will work but perhaps you have something in place to sort the CSS issue out that we don't?  There is clearly an issue with it trying to locate the old compiled-css123123123.css etc.  It's just how to overcome that link breaking that we are struggling with.


Many thanks

 

Rob1n

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • kwaoru
      By kwaoru
      Hi,
      I desperately need to deactivate the responsive function on mobile for reasons. It looks so messy with the responsive look on mobile and not navigating or informative at all as it is. 
      I searched for solutions online and tries some of those that I found but nothing worked out. Also I found a previous post on this forum says that this theme pagelines DMS is not meant to be build to deactivate the responsive function... 
      Also tried with widget such as WPtouch to edit the mobile look a little more informative but as I am using "single page" theme on pagelines, the frontpage(main page) never appears on those app.
      Seems like not compatible?
      If there is no way to deactivate responsive function or I'll have to recreate another page just dedicated for a mobile page? or change the theme completely and build a page from scratch?
      I have been searching for this for two days already...
      Could anyone wise and kind out there, please help me?
       
      Thanks,
×