Jump to content

Archived

This topic is now archived and is closed to further replies.

sethoof

Font Awesome Not Working in Firefox

Recommended Posts

sethoof

After the last update, the font awesome icons I was using in the ibox stopped showing up in firefox.  Is anyone else having this problem? Is there a fix? 

 

site is www.opfistula.org

user: flywheel

password: fistula

 

 

I saw this was a problem for other (non pagelines) people as well. http://blog.maxcdn.com/font-awesome-firefox-bug-fix/

 

Thanks in advance for your help!

 

Share this post


Link to post
Share on other sites
sethoof

Thanks, Danny.  Will give it a look and call flywheel to see if they can help me since its a CDN issue.  I guess its really a firefox issue...

Share this post


Link to post
Share on other sites
sheilahoff

I'm going batty with this.

 

On my dev site: http://www.solsara.hoffmangraphics.com the font awesome icons display fine in the bottom right of the banner (via Business Banner section)

On the live version: http://www.solsara.net they do not display, instead getting the empty boxes.

 

This is on the same server. And it's a restore of the dev site with no changes.

 

I've followed and tried everything on this thread to no avail. I give up. What can I do?

 

Thanks,

Sheila


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Simon

Its because somewhere you have 2 urls set.

 

One is http://solsara.net/ and the other is http://www.solsara.net/

 

FF does not allow cross site font loading... 

 

you have your page urls set to http://solsara.net/ but firefox is looking at http://www.solsara.net/ for the font. www is a subdomain.

 

Make sure your urls are the same.

Share this post


Link to post
Share on other sites
sheilahoff

Simon, thanks so much for looking. Your explanation made sense. I went into WP Dashboard settings and changed the url there to include the www. It still doesn't work. Is there more I need to do? Something in the site's hosting cpanel perhaps?


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Simon

The url firefox is using is www.solsara.hoffmangraphics.com Thats why its broken

Share this post


Link to post
Share on other sites
sheilahoff

HUH? That's the old dev site. I can bring up http://www.solsara.net just fine and the missing fontawesome icons are all that is wrong.

 

Where are you saying it's looking for solsara.hoffmangraphics.com? I'm not sure if this is:

1) a propagation issue

2) a misunderstanding on my part

3) a misunderstanding on your part.

 

I'm confused.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Simon

ALL the urls in the main css file are using your old url. Did you click the flush button to rebuild the css file after you changed the urls?

Share this post


Link to post
Share on other sites
sheilahoff

Bless you! That did the trick! I've never needed to use that trick before. Great thing to know. THANK YOU!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
umar

For me font awesome characters show blank empty boxes in both chrome and FF,

Share this post


Link to post
Share on other sites

×