Jump to content

Archived

This topic is now archived and is closed to further replies.

nfp1900

bbpress pagelines plugin and 1.1.3 is rendering blank pages on forums

Recommended Posts

nfp1900    29
nfp1900

Hi

 

I installed the bbpress integration plugin to render the design correctly in DMS. The root of the forum is ok but clicking on any other forum is simply rendering blank pages and the editor doesn't load. 

 

I did have membership protection enabled but removed all of that and it's the same issue. This is the root, click on any forum and it does nothing:

 

http://citywomen.org.gridhosted.co.uk/only-connect-3/

 

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Can you enable WP_DEBUG mode and see if any errors are printed and if so, please add them to your reply.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

I enabled debug and it didn't produce anything, it was just the white screen. I disabled the bbpress Pagelines integration plugin and the navigation to forums is re-enabled and the editor loads. Reactivated the plugin - white screen again. 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

So bbPress works without the integration plugin but when enabled it causes a white screen ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

you get the forum root as per the URL above but navigating to other forums gives you a white screen when the plugin is enabled

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

I have just installed bbPress without the old PageLines bbPress integration and I have no such issue.

 

To create the Forum index, I removed the Content/PostLoop section and replace it with a MediaBox and added the Forum topics shortcode. For the other pages I simply used the Content/PostLoop.

I have just created several forums and several topics and not ran into any white screen.

However, I had several white screens when using the PageLines Framework bbPress integration, its my understanding that bbPress or BuddyPress integration plugins do not need to be used anymore.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

Ok, thanks for looking into it. So maybe a good idea to ditch that recommendation from the docs for DMS. I'll delete the plugin and continue as before. 

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

Danny, did you not find putting the forum shortcode into a mediabox messes with the design? I'm finding it doesn't look quite as neat with additional padding and space between the search bar and forums . Is using a mediabox just a shortcut? What is the advantage over using the content/postloop?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

I just tried with the MediaBox for speed to be honest, as the forums were quite busy. In regards to the styling, I don't personally use bbPress so I wasn't aware of any styling issue to begin with.

So if you use the Content/PostLoop it looks better than when used in the MediaBox via a shortcode ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • camaran
      By camaran
      If i install bbpress 2.5.7 i have a white page in article content and in other page content, can you check if contect section work with the last versione of bbpress?
       
      From my test it's bbpress login widget to give me problem
    • theredbaron
      By theredbaron
      Hi guys,
       
      Hopefully someone can help me out on this one, as I struggling to find a solution!
       
      This is definitely a DMS2/bbPress issue, as I have tried it on a fresh install with no plugins. If I try to edit a forum reply, I am getting a post excerpt instead of the bbPress front-end editor showing. The editor works ok for editing topics.

      The WordPress admin bar is also being corrupted on this page (see screenshot).[attachment=2680:Screenshot from 2015-03-11 14:00:46.png] 
       
      This is a shot of the 'Edit Topic' screen which does work. [attachment=2679:Screenshot from 2015-03-11 13:54:23.png]
       
      The 'Edit Reply' page shows fine in Twenty Fifteen wp theme.
       
      I am getting no errors logged in DMS of from wp-debug.

      Please help because this is driving me nuts!  :hot: 
       
      DMS Debug Info
      WordPress Version
      4.1.1
      WordPress Debug
      Enabled
      Multisite Enabled
      No
      Current Role
      Administrator
      Framework Version
      2.1.9.3
      PHP Version
      5.3
      WP_DEBUG
      Yes
      WP memory limit
      40 MB
      WP MAX memory limit
      256 MB
      PHP memory limit
      256 MB
      Mysql version
      5.5.33
      WP Max Upload Size
      64 MB
      PHP POST Max Size
      64 MB
      PHP Max Execution Time
      30s
      PHP type
      Cgi-fcgi
      WebServer software
      Apache/2.4.9 (Unix)
      OS
      Linux
      Installed Plugins
      bbpress/bbpress.php
      dms-dev-tools/dms-dev-tools.php
      dms-plugin-pro/dms-plugin-pro.php
    • solosails
      By solosails
      I have DMS2 installed using a child theme, and BBPress forum plugin
       
      When I go to view a non admin user profile page, I get a 404 page not found error.
       
      The only page that will display is the Keymaster Admin account.
       
      I have followed a few threads here with the same issue and have managed to get the profile to display by dropping in a post loop section and enabling the legacy mode with view full content, however, this still leaves a jumbled 'post' preview at the top of the page.
       
      Any help much appreciated.
    • massmosaic
      By massmosaic
      Hi Pagelines Guru's
       
      I've installed BBPress on my staging website (rad.mosaicearth.com). 
      Here's a link to a forum on my site: http://rad.mosaicear...ure-discussion/. Here's another to another forum: http://rad.mosaicearth.com/forum
       
      I am told: "Fatal error: Class 'PageLinesIntegration' not found in /home/content/61/9474861/html/rad/wp-content/plugins/pagelines-bbpress/pagelines-bbpress.php on line 92"
       
      I found this thread: http://forum.pagelines.com/topic/32054-is-there-currently-a-working-bbpress-compatibility-plugin/ and installed  the plugin-pagelines-bbpress.zip from the package. I am still getting an error for BBPress on my pagelines site.
       
      I'm using wordpress 3.8, BBPress 2.02 and DMS 1.1.4. I'm fairly certain from Martin's response in that thread that BBPress isn't compatible with DMS. Can you plz advise?
       
      Also, wanted to ask what is the difference between pagelines and DMS? Is DMS just the name for the default theme of pagelines? Just want to be sure as that other forum post confused me.
       
      Thanks.
    • brianocar
      By brianocar
      Hello,
       
      I'm using the latest versions of Pagelines and bbPress. I've set up my bbPress forums but the resulting forums page doesn't look right at all.
       
      I've read about a plugin that makes PageLines work with bbPress but I can't find it, the most recent post being here. I emailed the helpdesk as advised but they directed me back here to the forums.
       
      Is there a working plugin that makes bbPress work in Pagelines? Alternatively, is there another forum plugin that will work with Pagelines? (preferably free and simple to use!)
       
      My forum does not really need to be integrated (visually) into the rest of my site - it can appear like a separate site without the Pagelines theme, menu, etc..
       
      Thanks,
      Brian
×