Jump to content

Archived

This topic is now archived and is closed to further replies.

janpeeters

1.1.3: Changes only visible after reset LESS/CSS cache and illogical margins?

Recommended Posts

janpeeters

I've seen two strange behaviors since updating to DMS 1.1.3 that I can't wrap my head around. I've deactivated plugins and researched my custom CSS but couldn't find what I could've done wrong myself. This is one the site www.lovo.nu

 

1) I use Firefox to preview my website when logged out. This saves me having to log out in chrome all the time. Since 1.1.3 I need to clear the LESS/CSS cache in Editor before I can see changes come through in Firefox. Normally it just needed a force refresh in Firefox to see the changes. I'm not using much custom LESS just the workaround for smaller ul/li that was posted on Better DMS. 

I'm using caching in the DMS Pro plugin but I suppose that this can not be the problem. I don't have any other external caching plugin like W3TC active atm.

 

2) I see different margins/paddings in Text box areas when logged in then when logged out (see screenshots). This puzzles me. I've looked many times over my custom CSS to see if I've done anything wrong there but couldn't find it.

http://cl.ly/image/3q1x0h1d0l02  (logged in, preview off)

http://cl.ly/image/1L1U2e2Z3n15 (logged in, preview active)

http://cl.ly/image/3u151R221f2f (logged out)

 

Thanks for any help.

 

Jan

Share this post


Link to post
Share on other sites
atcdomainsolutions

I am having major issues as well with number 2 from OP.  Padding is off big time when logged in but when logged out, extra padding seems to be added for some reason, which caused issues with a site where my client wanted sections much closer. 

Share this post


Link to post
Share on other sites
James B

When the DMS editor is active there is extra padding which the guidelines go in to help separate the sections visually so you can drag and drop etc. That's disabled when you turn the preview icon on.

 

Regarding the section caching, that will probably be the cause of the problem as clearing the cache allows you to see the live version in the other browser. I'll check with the dev team though to see if that is the case and come back to you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
janpeeters

Hi James B, 

 

I know that extra padding is added for dragging but with preview mode that padding normally collapsed so you could see a preview of your site as it would be to users. That is not the case anymore when logged in as you can see in the screenshots above.

Even when preview mode is active the extra padding is visible. This makes working of course a lot more complex. I'm not sure if this could be the problem but when logged in there is an extra line of code (maybe also for drag n drop) but there is a <br> in the code that might account for the extra height.

 

And regarding 2 that might indeed be the case, didn't think of this but because it's another browser it could well be. 

Just as a side note, I was also using Firefox as a workaround for the behaviour in 1) so I really hope this can be solved.

 

Thanks for looking into this.

 

Jan

 

 

When logged in:

 

<div class="textbox-wrap pl-animation textcenter " style="">
<strong data-sync="textbox_title"></strong><br>
<div class="hentry" data-sync="textbox_content">
<h2>Bijvoorbeeld</h2>
</div>
</div>
 
When logged out:
 
<div class="textbox-wrap pl-animation textcenter " style="">
<div class="hentry" data-sync="textbox_content">
<h2>Bijvoorbeeld</h2>
</div>
</div>

Share this post


Link to post
Share on other sites
Danny

HI,

 

I am not entirely sure what the issue is to be honest. Also, if you're using FireFox with the editor, this may well be related to that.

Would it be possible to provide a video via Jing of the issue please?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Hi Danny,

 

It feels a bit like you did your replies in a rush yesterday or I've not been clear enough. I'll try again.

There are two issues. The one with Firefox is about caching and it might very well be that I've been wrong to not deactivate the cache in the DMS Pro plugin when previewing in Firefox as James suggested. So I'll try that. That one is on hold for now.

 

But the second issue is as far as I can tell quite clear from what I had posted.

I've made new screenshots without any custom CSS to show you what's the case:

 

The spacing above 'Bijvoorbeeld' differs when logged in and having preview mode active:

http://cl.ly/image/2s0O2T332r2O

Then when logged out:

http://cl.ly/image/1O2a31453r0u

I've overlayed the two so it's (hopefully) more clear. It's alligned on the small text: 'manier die bij hen past'.

http://cl.ly/image/0P1E2M113m2h

 

The added spacing is not really handy when your developing a site. Therefore I used Firefox to get the right impression.

As far as I can tell the preview mode was quite WYSIWYG in previous versions of DMS but recently (1.1.3?) stopped being that. I think this is only with Text Boxes so maybe there have been changes to that section.

 

Hope this is more clear, thanks again!

 

Jan

 

ps: I'll try not too post combined issues the next time but post different threads to keep things more clear.

Share this post


Link to post
Share on other sites
Danny

I wasn't rushing my answer, I just interpreted to posts as though you were using the DMS Visual editor in FireFox. 

 

 

1. I am not having issue, I made several clear changes to my site, all of which were using custom CSS/LESS. When I view these changes in either Canary or FF, the changes are just with using refresh, I don't even need to clear the cache. Therefore, I am either not recreating your issue correctly, or your FF has some cache/cookie issue.

 

2. I have seen what you're referring to now and it is definitely related to <strong> and <br> tags that are there when the editor is on and not there when disabled. I have reported this.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Hi Danny,

 

thanks for testing 1. and sorry for my assumption and interpretation then ;-)

I'm going to research FF further and try with Safari too to see what happens.

 

Regarding 2. thanks. Looking forward to a fix.

 

Jan

Share this post


Link to post
Share on other sites
janpeeters

Explorer gladly doesn't run on the platform I'm working on ;-)

Had never heard of Canary, nice to know!

 

Thanks.

Share this post


Link to post
Share on other sites

×