Jump to content

Archived

This topic is now archived and is closed to further replies.

microsqueek

Activate dropdowns on hover not working

Recommended Posts

microsqueek    5
microsqueek

Hi, working on a new site, and having trouble with menus. The hover for submenu isn't working - parent page shows up in menu, subpage doesn't. The Active dropdowns on hover button is checked, but doesn't seem to do anything.

And, when I try to create a new menu, it won't let me add the subpage as a subpage, but keeps pushing it to be a top level page.

 

Site: http://betterworldgaming.com

Parent page: http://betterworldgaming.com/epets

Subpage: http://betterworldgaming.com/epets/support

 

Any idea what's stopping it from working, or how to fix it?

 

Thanks! 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hello microsqueek - if you can create an admin account for your Wordpress site and send the credentials to hello @ pagelines.com with a link to this forum topic in it we will take a look for you and see what is going on with the Menus. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hi I have taken a look at your settings and you may have some conflicting Custom CSS. Could you try removing the Custom CSS and see if this now works. 

 

Please let us know how you get on. 

  • Like 1

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
microsqueek    5
microsqueek

I thought that might have been it, too, and tried it before. You can see, I've taken all custom CSS out again, but it the hover menu still isn't working. Any other thoughts?

 

ps - even if the CSS had been conflicting, that's kind of a problem, as it was there for a reason, site just looks silly now...

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

From the looks of it you haven't created a custom menu and assigned it to the FixedNavbar. As your menu items are using the page classes, which indicates that its not an actual menu.

 

Therefore, create your menu, then assign that menu to the Fixed Navbar, you can find more information here - http://docs.pagelines.com/tutorials/adding-custom-menus

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
microsqueek    5
microsqueek

Funny, I tried that before too, and it didn't work. But tried again just now, and it's all better. In the end, I removed the custom CSS (saved it elsewhere for reuse), then it let me build and save my menu correctly. Assigned that one to fixed nav, saved, then put the CSS back in. Seemed to work.

 

Thanks both!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

No problem, happy to hear you issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
microsqueek    5
microsqueek

Really sorry, but just seen that the issue hasn't actually been resolved. In the menu, Support should be a sub-menu, but when I try to re-order the menu it simply won't become a sub-item. It snaps back to being a top-level item when you click save.

On the one time it did stay as a sub-item, the top-level button (ePets) wouldn't click through to its page. Are top level pages not clickable when they have a hover menu?

 

Any (new) ideas why this is acting up so much? The custom CSS has been taken down, I don't know what is interfering... 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

If you're having issues creating your Wordpress menu, it is likely to be related to a plugin or custom script. I have just created a custom menu with sub menu items and have no issues what so ever.

Therefore, disable all active plugins except for DMS Pro Tools and see if you're able to create your menu correctly.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
microsqueek    5
microsqueek

Danny, I've tried disabling all plugins, and redoing the menu. Still not working. I sent login deets to hello@ a day or two ago - do you think one of you could take a look and see what might be going on backstage? It's getting really frustrating.

 

Thanks.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Whats the email address you used to contact hello@pagelines.com ?

As I can't see any email related to the email address on or forum profile ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
microsqueek    5
microsqueek

It came from emma @ cultivateoxford.org. Sorry to be confusing!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Support Submenu is now a drop down.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
microsqueek    5
microsqueek

How did you do that?! Hero.

 

But... now the main link (ePets) won't click through to its page. How do we get that to work?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

I did by using the Wordpress custom menu, you simply drag to the right any menu you want to be a sub menu of the menu item above, read the article I linked you in my previous post or see the Wordpress codex for more information.

 

Regarding your ePets menu item, this is how the navigation has been designed by Bootstrap. If you have any menu that has child menus (sub menu) the parent item will no longer be a link, but instead an anchor which activates the sub menu.

 

If you do not like this functionality you will need to use a different menu, you visit our store for other menus or a plugin such as UberMenu.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
    • Dave
      By Dave+
      1) Toggle menu on mobile devices does not work properly, combination Chrome 56.0.2924.87 with Android 6.0.1

      2) Mobile / Default Menu > Set the primary/default navigation for your site. This will be used in the pop out mobile menu and as the default in navigation sections. Does not work.
    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • David
      By David+
      We are building a long-page scrolling site with Pagelines 5. Our menu is made with # links that go to a container's unique ID, e.g. container_ux7al6g
      This works, but it doesn't look great in the menu. Is it possible to assign a 'nice' # link, e.g. /#solutions ? 
      We used to do this in the DMS2 platform through a workaround, but that doesn't seem to be possible now. 
      Any suggestions? 
×