Jump to content

Archived

This topic is now archived and is closed to further replies.

FionaFell

Hunting for a CSS Tweak that will let me change the height of the HERO section?

Recommended Posts

FionaFell

Hi, I'm creating a website for a client here: http://theartspot.com.au/classes-events/

 

And the hero section that we've place her section headlines in are a bit too big. OK kind huge. 

 

Can anyone point me to the CSS id/class or code that I can tweak to make the height of the whole green area, shorter?

 

We're looking for around 150px with content centred vertically. 

 

Any help would be awesome. 

 

- Fiona

Share this post


Link to post
Share on other sites
josh1178
Identify the section area by clicking the pencil and looking for the section number next to the word 'section area'. Then just add the following:#pl_areaYOURSECTIONNUMBER .pl-content {max-height: 150px;}


if the number is c9a83e, you'd type the following into the css customizations area:#pl_areac9a83e .pl-content {max-height:150px;}

Share this post


Link to post
Share on other sites
Danny

FionaFell"] - Did @[member="josh1178 suggestions work for you?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
FionaFell

Would it be this number I'm looking for?

 

http://screencast.com/t/7bf9DjvVBT

 

(I clicked on the pencil of the Hero section)

 

I have this in my CSS

 

#pl_areacegqwzj .pl-content {max-height:150px;}

 

But am not seeing any change to the live site yet. Am I using the right reference ID #?

Share this post


Link to post
Share on other sites
josh1178

Try using #pl_areacegqwzj .pl-content {display:none;} temporarily just to be sure that you have the right area. If you do, it should disappear. If it doesn't you've got the wrong area. 

 

Or, perhaps try:

#pl_areacegqwzj {max-height:150px;}

Share this post


Link to post
Share on other sites
FionaFell

No luck, I guess I've got the wrong reference in place. 

Share this post


Link to post
Share on other sites
josh1178

I think I got it, have you tried #heroegqwzj {max-height:150px;}?

Share this post


Link to post
Share on other sites
FionaFell

OK the height is great now.  Thanks for your help tracking this piece of CSS code down.

 

My next concern, as a result, is how to position the content vertically?

 

Any help would be awesome. 

Share this post


Link to post
Share on other sites
James B

The easiest thing to do if you're just having text in the hero would be to change the % width of the text area in the hero section options. That would keep both instances of the hero with the text in the same position.

 

Otherwise you'll need to edit the margins/padding for each hero unit separately to get the text dead center.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • sakkthi subramaniyam
      By sakkthi subramaniyam
      Working on a very old site which has  pagelines framework theme. I need section plugin. so i can install postpins section. I have lost backup copy.
      Thank you.
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
×