Jump to content

Archived

This topic is now archived and is closed to further replies.

johndb

Bug: Short Code - Button Groups

Recommended Posts

johndb    1
johndb

Hello, I'm reporting a bug for Danny"] or @[member="martin to check and submit to github.

 

Placing the shortcode  for a button group into a DMS TextBox section does not work properly.

 

The shortcode itself displays as text either side of the buttons, and the buttons stack ontop of each other instead of side by side.

 

The shortcode works in the ContentLoop section which is how I've gotten around this problem. However there is one page where I need multiple rows of button groups so I'm not sure how to do this yet.

 

The short code also works correctly in the Hero section, and PopThumbs section. I have not tried it anywhere else.

 

I checked in the PL300 and Gavin Aldrich confirmed this bug and advise me to post this thread,

 

Thank you.

 

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Working fine for me. http://d.pr/i/1X2U

The issue is the Wordpress loves to add <p> tags so you have to remove all line breaks from the code. So instead of:

 

[pl_buttongroup]
    <a class="btn btn-important" href="#">Link</a>
    <a class="btn btn-important" href="#">Link</a>
    <a class="btn btn-important" href="#">Link</a>
[/pl_buttongroup]

 

Use it like this instead:

 

[pl_buttongroup]<a class="btn btn-important" href="#">Link</a><a class="btn btn-important" href="#">Link</a><a class="btn btn-important" href="#">Link</a>[/pl_buttongroup]
  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
johndb    1
johndb

Thank you Danny

 

This method is working for me.

 

Would it be worth adding a note about this to the PL docs? I copy and paste shortcode from the docs page, and then edit it to suit because I'm not a coder.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Yeah I will do, thanks for letting me know this resolved your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • RiverRat
      By RiverRat
      Hi I need to add a simple optin form on the landing page on the right of the slider. I want to have a background graphic. I was able to add the image background to the column, but adding the short code in the text box nested in the column did not work for Firefox, but seems to work in Chrome http://buff.ly/1ktuPpP
       
      How would I add a small opt in form to the right of my slider. I do have Gravity forms but wondering how to add the short code to the landing page of DMS. thanks
       
      http://buff.ly/1etPdq9
    • Toby
      By Toby
      Hi,
       
      I am trying to figure out how to use the shortcode for tabs, I have checked the Documentation under Shortcode>Tabs but there is no example so I don't know what to do with the shortcode.
       
       
      If anyone could provide an example of how to implement the shortcode I would greatly appreciate it.
    • infogroupsmb
      By infogroupsmb
      We have a custom header section with with a meta setting for phone number.  The section has a site wide default number and the specific pages can change their meta setting for the phone.  
       
      Now we want to use the header meta setting in the content in the page and/or in the content of other custom sections.  What would be your recommendation for accomplishing this?
    • LukeB
      By LukeB
      Hi I'm using ajax to load pages on my site but I am also using the Facebook like button short code http://support.pagelines.me/docs/miscellaneous/shortcodes/

      I need to reload the JS associated with this short code as the Facebook like button disappears when the page is loaded with JS. Could anyone assist me on the location of the file containing the JS? I have the reload code all figured out but I just need the file location.

      Any assistance would be much appreciated.

      Here's my homepage
      http://www.priceofmilk.co.uk/
       
      Link to a post where it will display normally on first load
      http://www.priceofmilk.co.uk/uncategorized/testt

      If you click through to a couple of posts you will notice the like button no longer shows up, it seems to display the first load of a page but if you keep clicking through posts it stops.

      The button should be displayed to the left of the following text beneath the post content 'Click like to get the latest music news, hottest tracks and more via Facebook.'
       
×