Jump to content

Archived

This topic is now archived and is closed to further replies.

tiltcreative

Responsive mobile design not working on forwarded sites

Recommended Posts

tiltcreative    0
tiltcreative

I have three domains, one is where the site is and the other two are pointed to that one.

 

I was just checking them on my iPhone, and the responsive design only works on the domain where the site is hosted - the other two just load like the regular web page. If I change my browser size on the computer, it works fine, it just doesn't work on the iPhone.

 

How can I fix this?

 

Here are the three domains:

newworkscalgary.ca

newworkscalgary.com

neworkscalgary.com (this is where site is)

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Is this issue now resolved ?

As they appear to be working responsively for me when I reduce my browsers width.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tiltcreative    0
tiltcreative

No, that's the weird part, it looks fine on the reduce browser but neither of the other two work on the iPhone. The main one does.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hello tiltcreative. 

 

Your two domains do not redirect to the site neworkscalgary.com - is this what is supposed to happen?  http://d.pr/i/7gvW 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
tiltcreative    0
tiltcreative

They do, it's just that the domain masking is on. I don't have anything on the two other sites.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Not sure to be honest, but it certainly has something to do with your domain masking. May I ask why the need to for the domain masking.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tiltcreative    0
tiltcreative

I guess it's not imperative, but we would prefer if they were masked. I am confused as to why it wouldn't work though, isn't the responsive stuff just in a css file? Why wouldn't it work on both?  Anyway, I have taken the masking off, for now, so it works. But if you ever have reason to address that, I'd love to know so I can switch it back.

 

Otherwise, I am really enjoying the DMS theme.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, I've had a look online and the most probable answer I can find is http://wordpress.org/support/topic/responsive-theme-not-responding-when-domain-forwarded which mentions 'frame forwarding', so rather than moving to the new url, it simply shows the other side in a iframe under the current domain name.

 

There's some links in that post which go through the different options you can set for the forwarding, see if your host can switch to one of them to see if it handles it differently.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
tiltcreative    0
tiltcreative

Oh, so it's an iFrame thing. Interesting. I guess I'll just have to leave it as is for now - I'll see if my host can change it to IPS forwarding.

 

Thanks for checking!

Share this post


Link to post
Share on other sites
James B    436
James B

You're welcome :-)


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • lionel1
      By lionel1
      Hi,
      I use on my home page " impulse module " but when i look on my iPhone the image is cut and not responsive .
      i only have this problem with this module not with the other one .
      thanks for ur help
      website / www.elonakane.com 
      Lionel 
       
    • kwaoru
      By kwaoru
      Hi,
       
      I have been using DMS and pagelines.
      I am facing to a huge trouble with the appearance of one of my page on mobile (smart phones) built with pagelines.
      However I haven’t come to any solutions to organise either edit the appearance of mobile view to look neat or deactivate the responsive function. 
      Now it looks totally messy on the phone...
       
      1. Is there any way to edit the appearance of the mobile version (responsive theme)?
      2. Is there any way to deactivate responsive function?
       
      If I could receive support from you to go thorough this process I would be happy to be a pro member. 
       
      Looking forward to hearing from you.
    • Paul
      By Paul+
      I have woocommerce store, product shows title and price fine until reduce screen with on a tablet/mobile phone the price and title gets removed?  Any ideas? 
      Here's an example page: https://thelaptopfixers.com/product/operating-system-re-install/
      Try it on both desktop PC browser then resize to mobile/cell phone size!  
      Thanks
    • kwaoru
      By kwaoru
      Hi,
      I desperately need to deactivate the responsive function on mobile for reasons. It looks so messy with the responsive look on mobile and not navigating or informative at all as it is. 
      I searched for solutions online and tries some of those that I found but nothing worked out. Also I found a previous post on this forum says that this theme pagelines DMS is not meant to be build to deactivate the responsive function... 
      Also tried with widget such as WPtouch to edit the mobile look a little more informative but as I am using "single page" theme on pagelines, the frontpage(main page) never appears on those app.
      Seems like not compatible?
      If there is no way to deactivate responsive function or I'll have to recreate another page just dedicated for a mobile page? or change the theme completely and build a page from scratch?
      I have been searching for this for two days already...
      Could anyone wise and kind out there, please help me?
       
      Thanks,
    • dougalperman
      By dougalperman+
      Hi there,
      I'm a big fan of Pagelines, and have been for years.
      I'm trying to control the size of video embeds and having some difficulty. I see that I can just paste the Vimeo video URL into the post and an embed widget will automatically appear, which is great. But the embed box created is much taller that the video (689 x 1000 pixels) so the content sits in the middle of a tall black box, which looks awkward.
      I tried using the full iFrame embed code from Vimeo, which solved the disproportionate embed frame size (or aspect ratio) issue, but despite specifying the dimensions I want (690 x 388), the videos displayed on the post are sized at 300 x 150 pixels.
      I can't work out how to change either.
      I'm using the latest version of Pagelines Framework (Pro) with the Agency them.
      Any help or advice very much appreciated.
      Thanks,
      Dougal
×