Jump to content

Archived

This topic is now archived and is closed to further replies.

Keith Vaugh

Responsive video shortcode

Recommended Posts

Keith Vaugh+    14
Keith Vaugh

Hi all

 

On our web site at https://www.magva.com/what-we-do/letterpress/ I have a youtube video linked defined by the short code:

 

[pl_video type="youtube" id="Wh0_gWqkzzs"]

 

For whatever reason these are not working at the moment in google chrome. They are working fine in safari.

 

Any ideas?

 

 

Share this post


Link to post
Share on other sites
Rob    547
Rob

Keith,

 

I don't see any video in Chrome or in Firefox.  That code should work in all browsers.  I'm not sure what's happening.  I'll set up a test on my own server and see what's going on.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

Did you add the shortcode to a TextBox or MediaBox?

 

I just tested it on my site without any trouble.  I'm just wondering if the container is somehow hiding it.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Keith Vaugh+    14
Keith Vaugh

Hi Rob

No its just added to the page inside

<div="row">

<div class="span6">[pl_video type="youtube" id="Wh0_gWqkzzs"]</div><div class="span6">Text</div>/div>

 

Its working fine in safari, not in chrome. Didn't check in firefox or IE

Share this post


Link to post
Share on other sites
Rob    547
Rob

Your code is broken.  Look at the closing /div>.

 

It should be </div>


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Keith Vaugh+    14
Keith Vaugh

Hi Rob

Its not broken on the site.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

I copied and pasted your code and added it to a page on my test site, the video displays correctly. Therefore, you most likely have a plugin or custom script causing a conflict.

http://d.pr/i/xrzK

 

You will see the screenshot above, that I have added "Header 5 with no Text ?" this is because in your code, you have the following:

 

<h5></h5>

Not sure why you add header tags and no use them?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Keith Vaugh+    14
Keith Vaugh

Thanks Danny

 

Will investigate the plugin's. Its strange that they still work in some browsers but not chrome!

 

The <h5></h5> was for spacing. Wanted the top of video to be aligned with the top of the text (just below its heading which was also a h5)

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

When I add the code to my site, I checked the following browsers Chrome, FF, Safari and Opera the video displayed in all.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
grahamd79    3
grahamd79

Hi, had a similar problem - since last update I get a blank youtube frame which just comes up with "an error occurred please try again later - learn more" message. It is the same in text box as postloop content. Any one else had a problem?

Thanks

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

grahamd79 - Can you provide a link to your site and also provide the code you have used please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

From what I can see the URL that is generated from the YouTube video isn't correct, what video are you trying to embed, can you provide a link please?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Your code wasn't valid.

 

You have a missing " before the tQQmq9X5lQw 

 

However, there does indeed appear to be some kind of issue with the responsive videos shortcode, as wen added correctly the video doesn't look correct. As you can see from here - http://d.pr/i/QcXU

I have reported this, your best option would be to embed your videos using this instead:

 

<div class="fitvids">
Your Video embed code goes here
</div>

 

Like so:

 

<div class="fitvids">
<iframe width="560" height="315" src="//www.youtube.com/embed/tQQmq9X5lQw" frameborder="0" allowfullscreen></iframe>
</div>

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×