This topic is now archived and is closed to further replies.

Site won't load properly in firefox when logged out

4 posts in this topic

Hi PageLines, 


First of all, thank you very much for your hard work in providing a great framework for free. 


I have been using Pagelines DMS (free) for all of my websites. It work great in Chrome, but when I tried it on (logged out) Firefox, it won't load properly. But when I tried it again while I logged in, it works flawlessly. 

What can I do to make this problem fixed? 

Here is the information about my installation from the pldebug


DMS Debug Info

WordPress Version

Multisite Enabled

Current Role

Framework Path

Framework URI

Framework Version

PHP Version

Child theme

PHP Open basedir restriction

PHP memory

Mysql version

PHP type

PHP User


Installed Plugins

Any help greatly appreciated.

Best regards, 



Share this post

Link to post
Share on other sites



Your site works fine in FIrefox.  However, I note that in the admin area, it is displaying a fatal error, which I believe is created by some code error, probably CSS.

This error: 
Fatal error: Call to undefined function setup_pagelines_template() in /home/u269747838/public_html/wp-content/themes/dms/index.php on line 50

I believe this is caused by either broken CSS code or a snippet of broken HTML.


Can you first clear the cache from your cache plugin, then deactivate it and other plugins?  See if that makes it go away.  If not, then you'd be best to test your CSS (if it's plain CSS or CSS3, not LESS) using a validator.

1 person likes this

Share this post

Link to post
Share on other sites

Thank you so much Rob. 
It really is working, and the error now has been handled thanks to your pointer.. 


Share this post

Link to post
Share on other sites

A pleasure to help! Glad it worked.

Share this post

Link to post
Share on other sites

  • Similar Content

    • DMS editor timeout in Chrome - how reinstall safely?
      By jeomiland+
      Was on the phone with client yesterday reviewing the site and the server slowed way down. Did a couple updates that may not have taken. Now cannot get back into the DMS editor for  I can see the site in chrome and firefox but the background image is no longer there. Can get into dashboard in chrome and firefox. Cannot get into DMS editor in chrome - get "Oops, There may be an issue loading." error no matter how many times I try.  My internet connection is not the fastest, but I can access other sites I've built in DMS - just not
      My question is,
      1) is there a safe way to reinstall DMS that will not trash the work done on the site? 
      2) Is there a way to see if something in the database got corrupted and how to fix? Since I can't get into DMS editor, can't get to the Flush Cache page to try that.
      Just turned on
      define('WP_DEBUG', true);
    • Canvas Area chopped off in Firefox
      By dreamsight+
      Fine in Chrome and IE. But the top is missing in Firefox.
      Any ideas?
    • Allow editing in Firefox
      By ryanpcmcquen
      I use the paid version of DMS 2 to develop sites. Firefox works just as well as Chrome for editing (if you change the user agent). Needlessly blocking the editor based on the user agent just creates more hassle than anything else. If you test the site in different iterations of Chrome's device emulation mode, occasionally DMS will think you are not in Chrome and you will have to refresh to get back into the front-end editor.
      At the very least, I would love to see an option to turn off this user agent detection so that those of us that are brave enough to use DMS in browsers other than Chrome can do so.
    • IE and Firefox issues media boxes
      By margie
      Good Morning!
      Just launched our site yesterday and I am thrilled to say, it all went very well.  Thank you for all your support along the way.
      In viewing the site on the different browsers, I have found two issues, both on the same page, that appear when using either Firefox or IE.  
      This is the page -
      1) The picture to the left of "Advanced Manufacturing Technology Development" moves into the text area when you re-size the screen.  
      2) The picture to the right of "Materials Characterization and Testing" is only this size (i.e., huge) when viewed with IE or Firefox and the picture does NOT scale in size as I drag the screen smaller.
      Any assistance is greatly appreciated.
      Thank you and have a wonderful day:-)
    • media box behavior in firefox
      By nadielp+
      Hi Everyone,
      I have page headings set in media boxes for each page...these display just fine in Chrome but when I look at the site in Firefox the subheads are huge, covering most of the pages. I don't understand what is up or how to address this issue. Any help greatly appreciated.
      The site is and the pages displaying this problem are archive, submit and mailing list.
      This had been behaving just fine in the past but I was attempting to use cleaner, more precise images for the subheads. The actual artwork is just over 80px high...very strange.