Jump to content

Archived

This topic is now archived and is closed to further replies.

alexb

DMS 1.1.1 - Disable Mobile View?

Recommended Posts

alexb

Just upgraded and dismayed not to be able to find 'Disable Mobile View' anywhere in post meta-settings?

 

Am I missing something?

 

Thanks

 

Alex

Share this post


Link to post
Share on other sites
Danny

Hi,

 

DMS is mobile ready and therefore, there isn't any method of disabling the responsive layout. Why do you want to do that ?

Also your screenshot doesn't really show anything apart from you have what looks like your comment form causing an issue, can you provide a link to your site please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
alexb

Thanks Danny

 

Before updating to 1.1.1 I was able to disable the mobile view in DMS 1.0.4 - presumably through Frameworks? There was a check box both in Pagelines>Site Options and also on individual pages. As soon as I upgraded that option vanished.

 

So now the entire site is doing this when viewed on an iphone or ipad:

 

http://www.alexbulgo.net/the-man-who-made-thunderbirds-go

 

There are a number of reasons why I would wish to disable the mobile view:

 

I designed the site layout very specifically and I would like to retain that design consistently in desktop and mobile formats

I want to create a custom menu design and not have to use the default mobile menu link that appears

and more importantly, it seems to scramble my design as shown above.

 

Is there anyway I can use Frameworks to disable it as before, except in 1.1.1 rather than in the previous DMS version I was using?

 

Cheers

 

Alex

Share this post


Link to post
Share on other sites
Danny

OK, you will probably want to back up your site and then revert back to the 1.0.4. Then enable v2 Compatibility mode and enable Mobile Mode again. Then update to 1.1.1 again.

 

The v2 compatibility mode was there to assist users migrating from PageLines Framework to DMS, there was a small inline notification informing users that these options will be removed in 1.1. It wasn't mean't to allow users to disable mobile view mode, this option probably shouldn't have been there from the start.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
alexb

Ok, thanks Danny - I'll give that a whirl.

 

I must have missed the notification. Glad the option was there - even though it was not intended for the purpose.

 

Unlikely I know but it'd be nice to have it back permanently though.

 

Alex

Share this post


Link to post
Share on other sites
Danny

Yeah the v2 compatibility mode isn't going to be reintroduced as it was only there for migration purposes, nothing more.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
radroz

How strange. I'm having the same problem in 1.1.1, and the site was built IN DMS. Compatibility mode was never an issue.

Share this post


Link to post
Share on other sites
greenfly

radroz - the V2 compatibility was there in DMS  before being removed in DMS 1.1. so likely you have been using this veen if you designed the site in DMS. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
radroz

Well, I've explained my issue in another post. The client is pissed. I need to get this fixed immediately.

Share this post


Link to post
Share on other sites
Danny

If you're experiencing the same issue as the OP, then you will need to follow the instructions I gave them above. The v2 compatibility mode wasn't their to design your site, it was there to migrate from PageLines Framework to DMS.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
alexb

Tried your suggestion Danny, but alas to no avail.

 

I guess I will stay with 1.0.4 until either I do a site redesign

Share this post


Link to post
Share on other sites
Simon

Add to functions.php

add_filter( 'disable_mobile_view', '__return_true' );

 

All the setting does is remove the following line from the HEAD

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />

Share this post


Link to post
Share on other sites
jennajonesdesign

Thank You SimonP! That is what I needed too. 

Share this post


Link to post
Share on other sites
envisage

Thanks, that's what I needed as well.

 

Responsive design is overrated if you ask me. In general it just makes navigation impossible and breaks the design.

Share this post


Link to post
Share on other sites
Danny

Thanks, that's what I needed as well.

 

Responsive design is overrated if you ask me. In general it just makes navigation impossible and breaks the design.

 

Maybe, but if your site isn't responsive, you're missing out on a lot of readers. If I visit a site on my phone and I have to scroll horizontally to view content I won't be there for long.

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tikawawa

I tried the code about to disable the responsive layout and it did not work. I am making my own responsive css layout using @media and the default width settings and actions are causing problems for me. Could please tell me how to disable it. Thanks

Share this post


Link to post
Share on other sites
James B

Disabling the responsive layout in DMS you have to add the line below to the functions.php or the customize plugin. I've just tried this on a test setup and it's currently working.

 

add_filter( 'disable_mobile_view', '__return_true' );


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
codeiscode

Why Disable Custom View? Pagelines is not optimized for being viewed on the most common Mobile Browsers? TBH I was shocked when i tried to view our Website on an Iphone.

Share this post


Link to post
Share on other sites
Danny

PageLines DMS fully supports modern browsers. If your site doesn't work correctly then its likely to custom code you have used. If you can provide a link to the site in question, we may be able to assist you.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Contact our helpdesk:

 

hello at pagelines dot com

 

Provide them with a link to your site, a link to this topic and your admin username and password.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
greenfly

Hi @codeiscode 

 

Thank you for the logon for your site - after logging in and looking at your site on iPhone Safari iOS7 everything looks ok. If you are unhappy with the layout then Aa few additions to your custom CSS targeted specifically at iPhones or certain devices will help to resolve this.

 

You can achieve this within the Pro Tools plugin -  you will see 'Browser Class' - enable this and you will be able to use your browser inspection tools to target the CSS for specific devices and remove any extra padding between sections on those devices . 

 

hope this helps 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

×