Jump to content

Archived

This topic is now archived and is closed to further replies.

suecockburn

Page Background

Recommended Posts

suecockburn+    2
suecockburn

The site I'm building has an image background on all of the pages. For the home page this is what we want, but for other pages that have text we need a background colour, so that the text is readable.

 

Can you point me in the right direction for this? The site is CultusLakeChristmas.ca and the page with text is http://cultuslakechristmas.ca/sponsorship/

 

Thanks,

Sue

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

To do this, what you want to do is remove the image you have set as your background and then use custom CSS to apply that background to your homepage only.

 

You can do this by prefixing your custom CSS with the .home class from the body tag.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
suecockburn+    2
suecockburn

Thanks Danny!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Sparkblender
      By Sparkblender
      I'm having problems defining one repeating background image to show across all my regions.
       
      This is what I did:
      I've defined a background image in the "Site Settings" --> "Color & BG".
      Despite this, why does my page show a solid background instead?
      See this: http://screencast.com/t/59DKUthL
       
      The Fixed Region's options offer the possibility to specify background options as well.
      I specified "No background" as a Background Theme, assuming that this would take the default site settings instead.
      See this: http://screencast.com/t/FRYzWOxqGM2N
      I tried selecting other Background Theme settings, but none of them produced the intended result.
       
      Please help.
      Thanks
    • amir
      By amir
      Hi,
      I added an image for the background under Site Options/Color Control/Background Image.  But the image shows up in the content area only.  (See attached image)  I like that the image shows up on the entire website.  I also tried all kind of different options such repeat vertically/horizontally, Tile, and etc.
       
      Could you please let me know what I am doing wrong?
       
      Thanks,
      Amir
       

×