Jump to content

Archived

This topic is now archived and is closed to further replies.

BentleyD

CSS Won't Take Effect

Recommended Posts

BentleyD+    2
BentleyD
So I've used the code below 5 other places on my website that are literally exactly the same on http://websitealright.com and it works fine. I tried it on the news section within the header and it won't take effect? The css selector is set for header-highlight6 and the code below works for every other highlight. What's going on?
 
 
 
.header-highlight6 .highlight-head {
font-size: 48.8px;
margin: 0;
position: relative;
top: 60px;
color: white;
}
.header-highlight6 .highlight-subhead {
margin: 0;
position: relative;
top: 60px;
color: white;
}
 
Even though I'm editing local settings it's reflecting the changes on multiple pages??

Share this post


Link to post
Share on other sites
fliptheu    4
fliptheu

As for things not taking effect, try using !important after a rule:

 

top:60px!important;

 

Does that have any effect?


fliptheu

"Finding beauty one picture and one pixel at a time."

http://www.fliptheu.com

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Turn off your Total cache plugin and clear the cache file, that will block the css changes as they're made in the front end of the site on the live page. Need to keep the cache plugin off when making all your edits :-)


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

James B"] @[member="fliptheu Hey guys, I tried both of your solutions with no luck of change. Again, I never had this issue until I updated. I'm really in a time crunch and need to get this site finished by the end of the day friday, so anything you could do to help before then would be very appreciated. Thank you!

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

If you click on news and on blog on the menu the local settings for "news" are reflecting on both pages. That should also not be happening.

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

James B I have now completely removed W3 Total Cache and I am still getting no css changes and local setting are still reflecting on multiple pages.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hello Bentley 

 

Using a CSS validator i pasted in your custom CSS and it returned  22 errors http://d.pr/i/vDxu with your CSS relating to the following code http://paste.pagelines.com/M6lpQH0f

 

I then made a small addition to your CSS as below 

 

h3 {
  color:green;
}

 

this didn't work - i then removed the CSS from the paste above and it then did work http://d.pr/i/ij7p

 

The error appears to be with  with the CSS you are using. Any input error in the code and none of your CSS will work. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Also i have checked your debug information http://websitealright.com/?pldebug=1

 

Please contact your host and ask them to update your PHP (current version is PHP 5.4) as you have the following active which are no longer needed and have been known to cause issues 

 

PHP Magic Quotes gpc
Yes! Deprecated as of PHP 5.3 and removed in PHP 5.4

 

PHP User

Posix functions are disabled on this host!


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

Martin Davies I removed all the .example code, which fixed the css issue,  still I am having my local options change global settings. For instance I chose local on the blog page and made the heading say blog and now on the news page it says blog too? Whats causing this? 

 

Also why was my box shadow code ".example" (the selector) causing the issue? Can I use box shadows?

Godaddy's hosting only has 5.3 PHP

 

I'm not having any issues on my other sites that i'm running DMS on Godaddy

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Taking a look at the blog title issue fo ryou now. 

 

With regards the .example - try using a totally unique selector (if you created this yourself) like Bentleyexample (or something like that) 

 

also please try using the Hex color code rather than the name 

 

try    

 .box-shadow(0 0 3px #000000); 

 instead of 

.box-shadow(0 0 3px black);

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

I set up the box shadow as you reccomended and it seems to be working so far. Thank you! I am still having the local options blog title issue though. 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

great news RE the CSS & box shadows 

 

Please do not make any further changes to your site and i will take a look now. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

Martin Davies Okay leaving it alone now

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

The highlight section you have added the information to is in the header. Move the highlight to the template of the page and then add the local settings there and you can then do this for each page. Header is the same on each page. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

I switched it to the Template and am still having the same issue.

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

Martin Davies Any ideas of what I can do?

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

Okay, so i've narrowed it down and I cant change the highlight between "Post category" pages, but i can between "Pages". What do you think the issue is? I want to have a different header for each category.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

If you want to have a different image per category, this isn't currently possible at the moment, I am not sure if this is a bug. However, I have reported this myself, as I was trying to do the same thing and have a different banner image per category.

 

In the meantime, you could use a CSS, to add all the images then hide them per category using one of the following classes located in the body tag to prefix your custom CSS. Which will only display the image for that category.

 

.category-name

.category-id


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

Danny That seems like a pretty big flaw considering this was an option in previous version of pagelines and was a huge reason why i decided to pay for DMS. I have no idea how i would implement it this with css (When you choose to hide, it hides on all pages) and why no one told me this earlier this week when i started this thread. I have expressed over and over again that i am in a time crunch and this website is due at the end of today for work. I need to figure out how to make this possible ASAP. I would really appreciate detailed instructions. Thank you.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Bentley - add all the content to the pages and i will show you how to hide page by page. it is quite simple 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

Martin Davies Hey Martin, I have now made the header/highlight image for each category. They are just stacked at the moment. What is my next move? By the way thank you very much for the help!

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Ok thanks - Please do not make any changes whatsoever. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
BentleyD+    2
BentleyD

Martin Davies No changes will be made. Thank you

  • Like 1

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

OK here is how to do this 

 

Your pages News, Entertainment, Corporate, Hospitality, Institutional are Categories and therefore have category ID's -

 

You can see the category ID's by going to Wordpress > Posts > Categories then hover over the category names you will see the ID of the category at the bottom of the page http://d.pr/i/oAtq

 

Make a note of all the Category ID's. 

 

Next go to each section on the template and give the section a unique class - I have  done this for you. For example Industry news section's class has been given 'indnews' 

 

So to hide the Entertainment Client section on the news page you would use the following 

 

.category-9 .entclient {display: none;}

 

to hide all the sections other than the one you want on that category page add the unique Styling Class to the CSS. 

 

.category-9 .entclient .corpclient {display: none;} 

  • Like 1

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×