Jump to content
Sign in to follow this  
nielspeenanusoncom

Full width failure

Recommended Posts

nielspeenanusoncom    0
nielspeenanusoncom

I have a page (a page page) that I want to show in full width, without the sidebar. I've set the layout mode to "full width", but that doesn't work. Oddly, all the other layout modes work fine, suggesting that I'm looking in the right place. I've also tried the "hide sidebar" option, which works, but doesn't affect the layout (as expected). What would prevent full width layout from working, where other layouts work fine? Thanks. Niels

Share this post


Link to post
Share on other sites
cmunns    16
cmunns

That is odd. The only thing that would matter is if it's the blog page, in which case you'd have to set it globally to take hold.

Share this post


Link to post
Share on other sites
Andrew    201
Andrew

Tested on my local and it works fine... Nothing happens when you set the default layout to 'full width'? Do you have a live link?

Share this post


Link to post
Share on other sites
nielspeenanusoncom    0
nielspeenanusoncom

It's on an internal server for now, but I tracked it down to this: Everything is correctly full width until column-wrap div. It's being set to 480px: .fullwidth #pagelines_content #column-wrap, .fullwidth #buddypress-page #container { width: 480px; } Where are the columns configured?

Share this post


Link to post
Share on other sites
nielspeenanusoncom    0
nielspeenanusoncom

Compared it to your demo site just now, there it's 960px. Everything else looks the same. .fullwidth #pagelines_content #column-wrap, .fullwidth #buddypress-page #container { width: 960px; }

Share this post


Link to post
Share on other sites
nielspeenanusoncom    0
nielspeenanusoncom

Ok, solved it, but I think there's a bug somewhere: I figured out that in the database, in the pagelines-settings, the maincolumn_width value for fullwidth was 480. In the admin section however it said 960. I did "Save Options" a few times, but the value in the database did not change. So I resized to 940, saved options, then back to 960, saved again, and that seemed to successfully reset things to 960.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×