Jump to content

Archived

This topic is now archived and is closed to further replies.

amussa

updated then got: "can't write to your servers file system"

Recommended Posts

batman    389
batman
ashbybp
A pleasure if I could help, this is the live of the superhero.
:D
We all learn together in the forum.
Regards
Carlos

Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
sheilahoff+    63
sheilahoff

I too am seeing this error. Interestingly I only see it in Chrome and not in FireFox. And I've checked via FTP and my upload folder was CHMOD to 777 already. I've tried making it 705 as shown above. And I've added the PL Pro plugin though I'm not sure what I'm supposed to do with it. I'm not at GoDaddy. I'm on my own VPS and I own all my files. And my WP was not installed with an installer either. I am able to add images and save so I'm not sure this scary message means anything. It says we can hide these notices, visit PageLines options panel. But i don't see where. I am not using any caching plug-ins and have not yet turned on caching in the Pro tool.

 

I'm glad PL put this message in to make it so they don't get so many complaints about slow loading...I'm not sure they'll find all these new issues are worth the trade off. As an end-user I certainly do not! Hope you straighten this out quickly. It's a mess.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Simon    247
Simon
Did you enable debug and see what the error reported was?
There is also an option to hide that notice
What 'mess' are you referring to?

Share this post


Link to post
Share on other sites
sheilahoff+    63
sheilahoff

I just noticed this entire thread is in the Framework section! I'm using DMS full version. The "mess" is the number of folks seeing this error message and not knowing what to do about it and staff having to respond to all of us. I currently have 6 DMS sites all of which I've upgraded to WP3.7 and DMS 1.1.1. Now I need to do SOMETHING to each of them to fix them for this error.

 

As for enabling the debug...I'm not seeing it anywhere. I'm assuming you mean in the PL Pro plugin? I see:

enable CSS

CDN settings

enable section cache

enhanced search

memory test

 

What am I missing?

 

AH...just found what I'm missing...debug and turning off messages are both in the DMS interface under Advanced. Will see what messes I find there.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Simon    247
Simon
It's under advanced settings in the dms editor

Share this post


Link to post
Share on other sites
sheilahoff+    63
sheilahoff

Thanks. I did find it. But I don't see any errors there at all.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Simon    247
Simon
Can you show me the URL?

Share this post


Link to post
Share on other sites
Simon    247
Simon
Doesn't work I'm probably seeing a cached page

Share this post


Link to post
Share on other sites
sheilahoff+    63
sheilahoff

??? I don't understand. It works for me. I don't have a caching plug-in and my browser is set to not cache and I haven't turned on the PL Pro section cache either. Have you tried just the website? it's http://www.mommyonashoestring.com


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well regardless of why i cant see your debug page, looking at the source of your page you fixed the error somehow because the css is indeed a CSS file now. 

 

Apologies to the original thread poster for the hyjacking

Share this post


Link to post
Share on other sites
sheilahoff+    63
sheilahoff

Interesting. I didn't do anything! Thanks for your help. I hope it helps the others seeing this error too.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
ashbybp    1
ashbybp

I have no idea what happened. Sorry guys. sheilahoff I'm glad your site's back to normal. @Simon_P I don't think I'm going to be able to fix the message until my theme updates;until the developer of Sophistique sends out the correct file for the update my site is pooched. Hope this works for someone else though. 


If I need help, or ask a question, please talk to me like a two year old. I'm new at this. Thanks!

 

If you're looking to publish a book on Wordpress (even for Pagelines only) for absolute beginners please contact me at mdunford@ashby-bp.com. I'm a book publisher.

Share this post


Link to post
Share on other sites
Simon    247
Simon

I have no idea what happened. Sorry guys. sheilahoff I'm glad your site's back to normal. @Simon_P I don't think I'm going to be able to fix the message until my theme updates;until the developer of Sophistique sends out the correct file for the update my site is pooched. Hope this works for someone else though. 

I updated that zip about 4 mins ago :)

Share this post


Link to post
Share on other sites
dawsonbarber+    19
dawsonbarber

I just updated and got the same message.

 

Sites are hosted by WP Engine.

 

Everything is up to date (WP, themes, plugins). 

 

All plugins - except DMS Pro Tool - are inactive.

 

Here's the debug information:

WordPress Version
3.7.1

Multisite Enabled
Yes

Current Role
Administrator

Framework Version

1.1.1

PHP Version
5.3

PHP memory

256

Mysql version
5.5.27-28.1-log

PHP type
Apache2handler

PHP User
Posix functions are disabled on this host!

OS
Linux

Installed Plugins
dms-plugin-pro/dms-plugin-pro.php

DMS Internal Warning
Less Subsystem
PL_NO_DYNAMIC_URL is set to true

Share this post


Link to post
Share on other sites
Simon    247
Simon

I just updated and got the same message.

 

Sites are hosted by WP Engine.

 

Everything is up to date (WP, themes, plugins). 

 

All plugins - except DMS Pro Tool - are inactive.

 

Here's the debug information:

WordPress Version
3.7.1

Multisite Enabled
Yes

Current Role
Administrator

Framework Version

1.1.1

PHP Version
5.3

PHP memory

256

Mysql version
5.5.27-28.1-log

PHP type
Apache2handler

PHP User
Posix functions are disabled on this host!

OS
Linux

Installed Plugins
dms-plugin-pro/dms-plugin-pro.php

DMS Internal Warning
Less Subsystem
PL_NO_DYNAMIC_URL is set to true

Pretty self explanatory, you have PL_NO_DYNAMIC_URL set to true somewhere, probably wp-config.php

Share this post


Link to post
Share on other sites
dawsonbarber+    19
dawsonbarber

Yup. Thanks, Simon.

Share this post


Link to post
Share on other sites
noomaking    5
noomaking

Can I hop on this a bit. I am getting the same error message. Not in Safari or Firefox, just Chrome. In Debug I get this error.

 

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials

I run my own server. How is this addressed?

Share this post


Link to post
Share on other sites
Simon    247
Simon

Can I hop on this a bit. I am getting the same error message. Not in Safari or Firefox, just Chrome. In Debug I get this error.

 

DMS Internal Warning
Less Subsystem
Unable to set filesystem credentials

I run my own server. How is this addressed?

This means WordPress cannot get direct access to the filesystem, probably because the files username/group is different from the username/group that php/httpd is running under.

Share this post


Link to post
Share on other sites
noomaking    5
noomaking

Is there a benefit to chase this issue? It seems a bit exotic technically. Just curious as to why the Less Subsystem is writing to the uploads folders? Is this a cacheing solution of some kind? How can I reconcile a  Normal User with the PHP User.

Share this post


Link to post
Share on other sites
Simon    247
Simon

It writes a css file. If it cannot write a static file then it loads the css from the database which of course is going to be slower.

 

There are a lot of ways to setup php to run as your username, really depends on how you installed php and the webserver...

Share this post


Link to post
Share on other sites
vogelwild    24
vogelwild

Hi Simon!

 

In my case you're right. different user/group. Would you tell me which folders and files must have the same group/usermame as php-user? Just for pagelines. Then I could change this files and folders... Thank you!

Share this post


Link to post
Share on other sites
Simon    247
Simon

Hi Simon!

 

In my case you're right. different user/group. Would you tell me which folders and files must have the same group/usermame as php-user? Just for pagelines. Then I could change this files and folders... Thank you!

it tries to write a file to wp-content/uploads/pagelines/ (assuming you are not using a custom uploads folder of course)

Share this post


Link to post
Share on other sites
vogelwild    24
vogelwild

Hm, thank you Simon. I changed the user/group of the folger "pagelines" to the php-user, but with no effect. are there any other files/folders where I should change the user?

Share this post


Link to post
Share on other sites
Simon    247
Simon

No thats the only one, what user/group did you set?

Share this post


Link to post
Share on other sites

×