Jump to content

Archived

This topic is now archived and is closed to further replies.

Framegirona

DMS and WPML

Recommended Posts

Framegirona

Hi,

 

I'm using DMS and WPML and is a good tandem to works. But I've a little issue. IF I use WPML on mode to get diferents subdomains for each language (IE. ca.mydomain.com, en.mydomain.com, mydomain.com, fr.mydomain.com) DMS only works with main domain/language (mydomain.com).

 

I think because I need to register each subdomain to DMS but I don't know how to do it.

 

Now I have WPML on subdirectories mode and it works fine because 

 

Can you help me please?

 

Website URL:  reunionsentrevolcans.cat (PSW: garrinada)
Framework Version: 1.1
WordPress Version: 3.6.1
Plugins in Use: WPML

 

Thanks a lot for your help

Share this post


Link to post
Share on other sites
Rob

Hi,

 

I've been looking into this as much as possible today. 

 

The only possible way I can find to handle this is via Multisite, with a setting in wp-config that let's DMS be the default theme for all subdomains.  The problem I find will likely be the issue of setting the language for each subdomain in DMS. The content isn't the issue, but DMS itself may not apply individual languages.  So, you would access sp.yoursite.com for Spanish, and the content will be in Spanish, but DMS might be in English.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

  • Similar Content

    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • JP
      By JP+
      Hello,
      We are working on a 2 languages site (https://liguecardioliga.be) with wpml, and lately the call of a category in the loops section (and all the sections requiring a category to select posts) doesn't work in the translated language. It worked well until recently so I wonder if it's because of a recent update (wordpress, wpml, pagelines, a plugin?). Anyone has the same problem? a solution?
      TIA
×