Jump to content

Archived

This topic is now archived and is closed to further replies.

erinhecht

DMS NavBar menu not loading on mobile site

Recommended Posts

erinhecht    0
erinhecht

Hi,

 

I have a DMS site set up with responsive layout.  I have created a custom NavBar using a menu configured in admin, and it works fine when viewed on a desktop.  However, the menu does not show up on the mobile site.  When I view it on a mobile device (iPhone), the menu includes only Home, Categories, and Tags -- and the Home page is empty.  The Home page viewed on desktop should include a Twitter sidebar and several post sliders but these don't show up on mobile.  I've tried creating another, new menu in admin and setting this to the Secondary Nav in Global Options in DMS, but that also didn't work.

 

An acceptable workaround might be to simply disable the mobile theme, if anyone knows how to do that.

 

Thanks in advance for any help,

Erin

Share this post


Link to post
Share on other sites
James B    436
James B

Are you using DMS 1.1? Are all those sections in the sidebar, I note you said twitter sidebar etc. There was an issue where the custom/default sidebar widgets were being displayed, this was logged as an issue and fixed in the latest update.

 

If that's not the case, are you making sure the custom nav is selected in the global navigation options - http://screencast.com/t/0AuYukMMiGd

 

If you could send us a link to the site and a screenshot of the settings if possible for the nav we'll take a closer look for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Is this now issue now resolved, as when I view your site on my iPhone, you appear to be using WPTouch plugin.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
erinhecht    0
erinhecht

Hi Adam thanks for checking.  It does look like the WPTouch plugin is somehow being used, although on my dashboard it does not appear to be installed (!).  Maybe DMS somehow incorporates it?  Anyhow, the issue is not resolved.  When you view the site on your phone, you see a menu that includes Home, Tags, and Categories.  Selecting "Home" does not show any actual content (compare to the desktop version of the site), and there are several other pages in the site that are not displayed.

 

Any help in solving this would be much appreciated.

 

Thanks,

Erin

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

DMS doesn't include the WP Touch plugin, therefore you must have it installed.

 

Also, the Mobile Menu is configured separately to your NavBar menu. You can configure it by going to DMS Toolbar > Settings > Layout & Nav > Primary and Secondary and select your menu from there.

The Primary is generally used for your main menu links and the secondary is used for sub menu items. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
erinhecht    0
erinhecht

Hi Danny, I do have the Layout & Nav configured with the custom page menu that I set in WP Admin: http://cogwheelproductions.com/screenshot

But for some reason this is not carrying through to the mobile menu.

 

I really do not have WPTouch installed.  The only plugin I see in my WP Admin is Akismet: http://cogwheelproductions.com/screenshot2

 

Thanks,

Erin

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

When I view your site and reduce the width of the browser your NavBar and Mobile NavBar work perfectly to how you have configured them. 

 

http://d.pr/i/swEY

Therefore your issue when viewing on a mobile device is related to your site using WP Touch, is your site Multisite, the plugin could be network enabled. Either way, that is your issue, as if you click disable theme when viewing on a mobile phone, the NavBar works.

So you need to find how your site has WP Touch active if you say it isn't installed, as it clearly is. Once this has been disabled, your mobile navbar will work.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
erinhecht    0
erinhecht

Aha!  Yes you are right, WPTouch is installed at a network level.  I'm working at a university and it is a multisite installation.  Thanks for solving this - I will ask them to disable for my site.

 

Erin

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

No problem :D


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • kwaoru
      By kwaoru
      Hi,
       
      I have been using DMS and pagelines.
      I am facing to a huge trouble with the appearance of one of my page on mobile (smart phones) built with pagelines.
      However I haven’t come to any solutions to organise either edit the appearance of mobile view to look neat or deactivate the responsive function. 
      Now it looks totally messy on the phone...
       
      1. Is there any way to edit the appearance of the mobile version (responsive theme)?
      2. Is there any way to deactivate responsive function?
       
      If I could receive support from you to go thorough this process I would be happy to be a pro member. 
       
      Looking forward to hearing from you.
×