Jump to content

Archived

This topic is now archived and is closed to further replies.

rsantiago

Stopping Pagelines Dynamically Serving CSS

Recommended Posts

rsantiago
Is there a way of stopping pagelines dynamically serving css? WordPress Version : 3.6.1 Framework Version : 2.4.4 Framework Build : 2.4.4

Share this post


Link to post
Share on other sites
Simon

Depends what the issue is, if you provide a url and turn on debug we might be able to assist.

Share this post


Link to post
Share on other sites
rsantiago

Hi Simon

 

The issue we have is that a css file is not being generated so its not being cached.

 

Is there a way to use a static css file?

Share this post


Link to post
Share on other sites
Simon

it WILL use a static file, if it can. If the file permissions are right etc.

Share this post


Link to post
Share on other sites
rsantiago

So can you tell me what folders and what files and what permissions?
 
I cannot seem to get this to work despite having looked at all the threads on the forum

Share this post


Link to post
Share on other sites
Simon

your wp-content/uploads folder.

Share this post


Link to post
Share on other sites
rsantiago

Hi

 

That folder is fully writable - it seems that the css file is not being written to it

 

Does a specific user need to own the folder? At the moment Daemon owns it

Share this post


Link to post
Share on other sites
Simon

Well thats the issue then, unless your username is Daemon of course, anything is possible.

 

add to your child theme functions.php

 

add_filter( 'render_css_posix_', '__return_true' );

Share this post


Link to post
Share on other sites
rsantiago

Hi

 

We are using the base theme not a child theme.

 

Is there a work around - we are looking to launch tomorrow and this has just come up as an issue.

 

 

is there any where else I can add the filter?

Share this post


Link to post
Share on other sites
Simon

The base theme is a child theme add it there.

Share this post


Link to post
Share on other sites
rsantiago

Sorry to be a pain but could you tell me which folder and file this filter needs to be added to?

Share this post


Link to post
Share on other sites
Simon

you said you have the base child theme, add to the functions.php in that folder.

Share this post


Link to post
Share on other sites
rsantiago

that would be wp-content/themes/pagelines/functions.php?

 

Sorry I'm not a developer

and everything has been working well except this.

Share this post


Link to post
Share on other sites
James B

Hi there, no thats thats the core file.

 

You'll need to install the base theme (which is like a blank child theme) and make that the active theme. You can download the base theme from here - https://github.com/bearded-avenger/nicks-base-theme

 

Then place that filter Simon provided within the functions.php of the base theme.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
rsantiago

Will this team work with Pagelines Framework? - it looks like its for DMS?

 

Should I install the Pagelines Base Theme (Starter Theme)?

 

Will I lose anything by activating either?

Share this post


Link to post
Share on other sites
Simon

either child theme would do.

Share this post


Link to post
Share on other sites
rsantiago

Will I lose my custom code or pageline settings by activating?

 

Can I switch back to the core theme without losing anything?

Share this post


Link to post
Share on other sites
Simon

As long as you have not edited any files... no you wont lose any settings.

 

Wordpress however DOES store a couple of settings on a theme basis, widgets and menus, so you might have to move them back.

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×