Jump to content

Archived

This topic is now archived and is closed to further replies.

abuzzelli

Pagelines Tab is blank

Recommended Posts

abuzzelli

Just signed up for and installed the pro version of dms. Problem is the pagelines tab is blank. I can't activate it or get to any options or anything.

 

See screenshot:

http://screencast.com/t/Yb57kfHdjAO

 

Share this post


Link to post
Share on other sites
Simon

Well all the options are on the frontend. The wp-admin tab only contains a couple of rss feeds and the backup css/js editor boxes.

 

Could be a PHP error. Enable WP_DEBUG in wp-config.php then see if any errors are printed.

Share this post


Link to post
Share on other sites
abuzzelli

Ok, this is the error I got:

 

Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 1966080 bytes) in /var/www/lu/lumapgh.com/public_html/NewSite/wp-includes/SimplePie/Item.php on line 2736

 

I don't really know what this means....Any help would be appreciated! Thanks.

Share this post


Link to post
Share on other sites
James B

Hi there

This issue is most likely caused by a PHP memory limit setting on your web server. Please ask your web host to increase the memory to 128M or 256M in the php.ini file.
 


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
abuzzelli

So, this site is on webhero which I'm not liking. I had them increase the memory, but I'm still getting this error. Any other ideas? 

Share this post


Link to post
Share on other sites
Danny

Can you provide a link to the site in question please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
abuzzelli

It's showing up all funky also, something isn't right here

Share this post


Link to post
Share on other sites
abuzzelli

Ok. Tried that and now I'm getting this error:

 

Notice: Constant WP_MEMORY_LIMIT already defined in /var/www/lu/lumapgh.com/public_html/NewSite/wp-config.php on line 91

Warning: Cannot modify header information - headers already sent by (output started at /var/www/lu/lumapgh.com/public_html/NewSite/wp-config.php:91) in /var/www/lu/lumapgh.com/public_html/NewSite/wp-includes/option.php on line 571

Warning: Cannot modify header information - headers already sent by (output started at /var/www/lu/lumapgh.com/public_html/NewSite/wp-config.php:91) in /var/www/lu/lumapgh.com/public_html/NewSite/wp-includes/option.php on line 572

Share this post


Link to post
Share on other sites
Jake

OK, so your WP config already had the WP_MEMORY_LIMIT line in there. Go ahead and remove the additional one you added and instead have a look for the one that's in there already and see what your limit is at. If you increase it to 64M and are still getting the error, next step is you'll want to reach out to your host and inquire if they can increase the server memory limit for you. 

 

As far as the funkiness you reported, I think this may be unrelated to you memory issue. It looks to me like DMS is not serving up your CSS and that is usually the case when you don't have at least one page and one post published (not draft) on your site. Can you confirm that you've got both of those?


Have you searched the forums yet or checked out the DMS user docs?

PageLines geek, blogging at MyUntangledLife.com

Share this post


Link to post
Share on other sites
abuzzelli

I checked WP config, the only WP_MEMORY_LIMIT line was the one I added. I took the line out, I'm still getting the original error. I've already contacted the web host and they already increased my memory limit.

 

I created a home page and a post, still looks all messed up.

 

What to do?

Share this post


Link to post
Share on other sites
Simon

Add to wp-config.php:

 

@ini_set('memory_limit', '64M' );

Share this post


Link to post
Share on other sites
abuzzelli

Just tried that, still getting the same errors. No new ones though! What next?

Share this post


Link to post
Share on other sites
Simon

If that last one does not work, you have absolutely NO way of raising the memory. Your host has blocked ini_set().

 

You could ask them to raise your php limit, but seeing as your sharing the same box with 300 other sites its unlikely.

 

What version of PHP do they use? Im guessing its 5.2

Share this post


Link to post
Share on other sites
abuzzelli

They're telling me it's 5.3. So I was trying to build my wordpress site in a subdirectory. Turns out my php.ini file needed moved out into the main directory and now everything is working. Hooray!!!  Thanks for all of your help!

Share this post


Link to post
Share on other sites
greenfly

Thank you for letting us know it is now working. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

×