Jump to content

Archived

This topic is now archived and is closed to further replies.

mfalle

DMS broken on homepage

Recommended Posts

mfalle

The DMS template for updating is broken on the homepage of my site. It works on all other pages. 

 

Please help!

Share this post


Link to post
Share on other sites
Jake

Hi mfalle - If you are able to access the visual editor on other pages it's likely there is a plugin or custom code on your homepage that's causing the conflict. I recommend you disable all plugins and remove any custom code and see if that solves the problem.


Have you searched the forums yet or checked out the DMS user docs?

PageLines geek, blogging at MyUntangledLife.com

Share this post


Link to post
Share on other sites
crunchnet

I have exactly the same problem. Plugins installed: 

  • DMS Professional Tools
  • Akismet (with key installed)

I have pagelines activated although that was this morning and I'm not sure when the API problem started. Could it be something to do with that?

Share this post


Link to post
Share on other sites
greenfly

crunchnet Please could you create your own topic 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly

Hello mfalle. 

Try this - Go to Wordpress > Settings > Reading and set your home page to particular page from the drop down . - The DMS editor will appear on your site. 

Let us know how you get on. 

 

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
mfalle

That doesn't help at all. I knew I could get the editor on other pages. I still need to be able to edit the homepage where there's a slideshow enabled, etc.

Share this post


Link to post
Share on other sites
greenfly

Hello @mfalle 

 

Can you see the visual editor now? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
mfalle

Yes, but cannot see my slideshow, my boxes, etc.

Share this post


Link to post
Share on other sites
greenfly

Hi Melissa 

 

I went into Wordpress > Settings > Reading and selected a page for your home page. The problem is that your pages do not have any templates assigned to them. http://d.pr/i/j2EU

 

Create some templates with boxes etc (you currently only have the default templates) and then assign them to the relevant pages, 

 

I have since gone into the Wordpress > Settings > Reading  and removed the changes i made so that you can see how this was done yourself. 

 

For help with adding templates ot DMS please see here. http://docs.pagelines.com/configure/using-templates


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
mfalle

Why is this only a problem now with the upgraded version?

Share this post


Link to post
Share on other sites
greenfly

I am not sure there is a problem per say just that none of your pages have any unique templates to use created by yourself. None of the pages have any templates assigned.

 

Have you created templates and assigned them to pages and they have not appeared? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
mfalle

No. I created my homepage based and the inside pages without templates. It was fine until I updated to this new version. How do I create a template for the homepage? I can't use the editor on my homepage because it is all messed up. 

Share this post


Link to post
Share on other sites
mfalle

I used the default template. I notice it's saying the "Feature" template for the homepage. I can't use the editor to change it to Default. Are you able to do this for me?

Share this post


Link to post
Share on other sites
greenfly

Which page would you like to use for your homepage? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
mfalle

The one that I originally set up as the homepage. The default page. I do not wish to assign a specific page to the homepage.

Share this post


Link to post
Share on other sites
greenfly

Creates some post for your blog to display and this should work. 

 

You currently have no posts for the page that dynamically shows blog posts to show. If you see what i mean ? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly

Hello @mfalle 

 

You havent set a static page for your home page so by default it is showing  your most recent posts. As there is no content DMS is not loading the CSS therefore not displaying the page properly. 

 

In order to use the front page you will need to select a front page if you ar enot going to show posts. 

 

You can see the settings for this in Wordpress > Settings > Reading  http://d.pr/i/qnVA


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

×