Jump to content

Archived

This topic is now archived and is closed to further replies.

flourishdesignstudio

NavBar Icon

Recommended Posts

flourishdesignstudio

Hi There! I have placed a fontawesome icon in the NavBar, but some strange characters are showing up in front of it. Can you help me figure out what is going on? http://carolbushberg.com/welcome-home/

 

Thank you!

Share this post


Link to post
Share on other sites
Rob

Hi,

 

How did you apply the font-awesome icon?  I've done this before and had no problem. 

 

Did you apply the code to the link or to the label?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Jake

Hi flourishdesignstudio - You've just got a couple of characters out of place in your code at 

 

<a icon-home"="" href="http://carolbushberg.com/welcome-&lt;i class="><span class="fontawesome-text"> home</span>/"&gt;<i class="icon-home"></i><span class="fontawesome-text"> home</span></a>

 

I think you want to remove what's in red?


Have you searched the forums yet or checked out the DMS user docs?

PageLines geek, blogging at MyUntangledLife.com

Share this post


Link to post
Share on other sites
flourishdesignstudio

Jake"] @[member="Rob Thanks for taking a look!! :)

 

I don't know where those other characters are coming from. They are not ones that I added anywhere.

 

I used a plugin called Font Awesome Menus, for lack of figuring out any other way to accomplish it. If you have another suggestion, I'm all ears! :)

Share this post


Link to post
Share on other sites
Rob

In Dashboard > Appearance > Menus, in editing a single menu item, the link should just be a standard URL.  In the Label field, you'd add this

<i class="icon-home"></i> home

In the actual link, just add

http://carolbushberg.com/welcome-home/

with no extra code, links, classes, IDs or spans.  Wordpress will add the a href and closing </a tag.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
flourishdesignstudio

Rob Thank you so much! That worked like a charm!! I really appreciate the help and quick response! :)

Share this post


Link to post
Share on other sites
Rob

Always happy to help!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
flourishdesignstudio

One more thing... do I need that extra plugin to make that happen? When I disabled it, I ended up with 2 icons. 

Share this post


Link to post
Share on other sites
Rob

No, you don't need the plugin, but I suspect that before you disabled it, the plugin added an extra icon.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
hansonexperience

Hi Rob I also did this on http://www.hansonexperience.com/blog/ but I cannot see the icons for home, video and photos. Besides this I find the font type not the clear/bright white.

How can I change both?

Share this post


Link to post
Share on other sites
Danny

Because your code isn't correct, you currently have this:

 

<i class="icon-home"></i>

 

use:

 

<i class="icon icon-home"></i>

 

and if you're using the latest version of DMS use you can also use:

 

<i class="fa fa-home"></i>


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
hansonexperience

Danny thx. I must have been blind :-)  What about my question of having the font type more bright white? I find they are not that bright. How could I change that?

Share this post


Link to post
Share on other sites
Danny

You're going to need to create your own topic, as this topic is over 6months old and has already been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
hansonexperience

Danny Ok will do that. Thx

Share this post


Link to post
Share on other sites

×