Jump to content

Archived

This topic is now archived and is closed to further replies.

kajort

PHP Warning Message after migration to new host

Recommended Posts

kajort

hi there -

 

just migrated a site from dreamhost to media temple via backup buddy. it worked, but i'm getting this message "Warning: Invalid argument supplied for foreach() in /nfs/c08/h02/mnt/116875/domains/dev.barbarycoastrevue.com/html/wp-content/themes/dms/includes/library.extend.php on line 83"

 

i asked media temple and they didn't know what was going on. i originally uploaded to a folder in the html folder, then deleted that and created a subdomain, just to try something different. got the same msg.

 

sorry, i don't know php and what is causing this...maybe you might have an idea?

thanks!

 

http://dev.barbarycoastrevue.com/

Share this post


Link to post
Share on other sites
Danny

Hi,

 

First can you disable all active plugins and enable PL Debug mode please. (DMS Toolbar > Global Options > Advanced)

 

Also, were you using a child theme on your previous host ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
kajort

yes, i am using a child theme (and this is my first time using one). i did notice that line 83 refers to a a child theme.

 

sadly, i can't log into dashboard, and get this when i try: 

Warning: Cannot modify header information - headers already sent by (output started at /nfs/c08/h02/mnt/116875/domains/dev.barbarycoastrevue.com/html/wp-content/themes/dms/includes/library.extend.php:83) in /nfs/c08/h02/mnt/116875/domains/dev.barbarycoastrevue.com/html/wp-login.php on line 384

Share this post


Link to post
Share on other sites
Jenny

Disable all of your plugins to see if the errors remain.

 

Also, be sure DEBUG is set to FALSE in the wp-config.php file.


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
Simon

Well that line 83 is looking for php files in your child theme folder. Do you have any files in there?

Share this post


Link to post
Share on other sites
kajort

I only have style.css in child theme folder...this is my first attempt at working w/ child theme. 

Share this post


Link to post
Share on other sites
Simon

Add a functions.php file.

Share this post


Link to post
Share on other sites

×