Jump to content

Archived

This topic is now archived and is closed to further replies.

Tehbeardedgamer

Hero Section, Transparent IMG background.

Recommended Posts

Tehbeardedgamer

I am using a hero section, My hero section background is transparent, but the image box inside it is filled with my default content filler color. I cant seem to find out where to change the css to make the Image background transparent.

 

http://fall2gravity.com/mgc/?page_id=14

 

A link to the page in question. All the images are PNG. I did cut out the background in PS.

 

Thanks in Advance!

 

Beard

 

EDIT:  I will also need the code to change it.

Share this post


Link to post
Share on other sites
Danny
Hi Beard, Add the following to your custom code.
#site .section-hero .pl-imageframe {
background: rgba(0, 0, 0, 0);
border: 0 none;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Tehbeardedgamer

Hi Beard, Add the following to your custom code.

#site .section-hero .pl-imageframe {
background: rgba(0, 0, 0, 0);
border: 0 none;
}

Thank  you.

Share this post


Link to post
Share on other sites
Danny
No problem.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
tecjaseplym

Hi I'm using the latest version of DMS and when I add this code to the custom CSS it has no effect. Can you please help. I need to add hero sections with png pictures that have no background or border.  Thanks

Share this post


Link to post
Share on other sites
greenfly

Could you start your own Topic please with links to your site and we can take a look at this for you. It is likely the code will be different for your setup. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
tecteamplymouth

Thank you I found the correct code on the DMS forum after registering our paid account correctly.

Share this post


Link to post
Share on other sites
Danny

Thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Shima

Hello,

 

I'm having the same problem, but it started today after upgrading DMS to 2.0.3, I was using 2.0

 

The hero is in a section with a background image.

 

The hero image is a transparent PNG, and now in version 2.0.3 there is a white background in the image.

 

And without a image configured in the hero you can see a white square with round borders.

 

Using the CSS suggested in this thread the the image is now transparent, but the border is still there, as you can see in this page:
 

http://dev.zooming.com.br/construtor-de-sites/

 

How can I fix that?

 

Thanks,

Alexandre

Share this post


Link to post
Share on other sites
GetMeWebDesign

awshimagmailcom you need to add in to that CSS

 

box-shadow: none;

 

Chrome Developer tools are very useful to identifying and changing CSS on your site before implementing on your live site


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
corykbarros

I'm having the same issue, but the opinion to insert box-shadow:none; doesn't work for me. I'm posting into Inline CSS Styling. Are there any other tips? 

 

Hello,

 

I'm having the same problem, but it started today after upgrading DMS to 2.0.3, I was using 2.0

 

The hero is in a section with a background image.

 

The hero image is a transparent PNG, and now in version 2.0.3 there is a white background in the image.

 

And without a image configured in the hero you can see a white square with round borders.

 

Using the CSS suggested in this thread the the image is now transparent, but the border is still there, as you can see in this page:
 

http://dev.zooming.com.br/construtor-de-sites/

 

How can I fix that?

 

Thanks,

Alexandre

Share this post


Link to post
Share on other sites
GetMeWebDesign

corykbarros you are adding it to the wrong place. It needs to go with Danny's code and with box-shadow: none; added ie :

 

#site .section-hero .pl-imageframe {
background: rgba(0, 0, 0, 0);
border: 0 none;
box-shadow: none;
}
 
This needs to be placed in your </>Custom (in DMS live editor) or in WP Admin > DMS Fallbacks > Custom LESS

Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×